0

On my VPS (centos 6.7 64x, 2 cpu's and 3gb ram) I have setup a WP MU(Memory usage: 53.97 MByte)and many times I have a blank page when I make a post draft or publish/updating it, or when I want to move as an admin to another option in wp.

I have added on the top of the file wp-config.php

define('WP_MEMORY_LIMIT', '256M');
define('WP_MAX_MEMORY_LIMIT', '512M');

Also, by doing 'inspect element on chrome, I noticed that it shows me this this error:

Failed to load resource: net::ERR_CONTENT_LENGTH_MISMATCH

I enable the debugging

// Turn debugging on
define('WP_DEBUG', true);

// Tell WordPress to log everything to /wp-content/debug.log
define('WP_DEBUG_LOG', true);

// Turn off the display of error messages on your site
define('WP_DEBUG_DISPLAY', false);

// For good measure, you can also add the follow code, which will hide errors from being displayed on-screen
@ini_set('display_errors', 0);

I decided to make a new post and save it as a draft. It showed me a blank white page while it was saving it. And I got this on debug.log

[22-Nov-2015 21:37:02 UTC] 
--------------------------------------
REQUEST: /wp-admin/post.php


[22-Nov-2015 21:37:04 UTC] 
--------------------------------------
REQUEST: /wp-admin/admin-ajax.php


[22-Nov-2015 21:37:04 UTC] 
--------------------------------------
REQUEST: /wp-admin/post.php?post=34890&action=edit&message=10


[22-Nov-2015 21:37:10 UTC] 
--------------------------------------
REQUEST: /wp-admin/admin-ajax.php


[22-Nov-2015 21:39:04 UTC] 
--------------------------------------
REQUEST: /wp-admin/admin-ajax.php

I never had this problem before (I use the same theme/plugins) I upgrade (centos from 5.5 to 6.7 64bit)the os of the server(I don't if this has something to do with the problem). I use the same theme/plugins.

Update I increased apache/php limits by adding the following 2 lines in /etc/httpd/apache/conf/php.conf

FcgidIOTimeout 400

MaxRequestLen 20468982

# This file was automatically generated by the Cpanel PHP Configuration system
# If you wish to change the way PHP is being handled by Apache on your system,
# use the /usr/local/cpanel/bin/rebuild_phpconf script or the WHM interface.
#
# Manual edits of this file will be lost when Apache is updated.


# Fastcgi configuration for PHP5
LoadModule fcgid_module modules/mod_fcgid.so
MaxRequestsPerProcess 500
AddHandler fcgid-script .php5 .php4 .php .php3 .php2 .phtml
FcgidWrapper /usr/local/cpanel/cgi-sys/php5 .php5
FcgidWrapper /usr/local/cpanel/cgi-sys/php5 .php4
FcgidWrapper /usr/local/cpanel/cgi-sys/php5 .php
FcgidWrapper /usr/local/cpanel/cgi-sys/php5 .php3
FcgidWrapper /usr/local/cpanel/cgi-sys/php5 .php2
FcgidWrapper /usr/local/cpanel/cgi-sys/php5 .phtml

# End of autogenerated PHP configuration.
FcgidIOTimeout 400
MaxRequestLen 20468982

Before, every time I were publishing/update or draft a post it was showing the problem on every thing. Now, the problem is random since I increased the apache/php limits. Does it mean that something else (how can I find it?) is putting load on vps or do I have to increase more the apache/php?

I have added w3tc plugin and optimised the sites but it didn't change anything. Should I add apcu or memcache / memcached combined with varnish or more RAM?

P.S.:This is my.cnf in the case that is needed as extra info to fix the problem that I have.

  • @s_ha_dum I searched with these keywords "White blank page wordpress net::ERR_CONTENT_LENGTH_MISMATCH" and I din't find anything that helped me. So I post it here.. – Alex Nov 22 '15 at 22:26
  • You post no code. You post, at best, a truncated error message. You don't mention theme, plugins, or what you've already tried. You probably don't have debugging enabled. And you want someone to guess what the problem is and solve it for you? – s_ha_dum Nov 22 '15 at 22:37
  • Post updated. I hope now its ok for someone to help me :) – Alex Nov 22 '15 at 23:10
  • Did you do the update or did you host do it? – s_ha_dum Nov 22 '15 at 23:14
2
There will be many reasons for blank page, you have not mention version for wp, php etc.
**To solve wordpress blank page issue follow the steps**
  1. disable all plugin and try (if there is an error in plugins then enable 1 by 1)
  2. switch to default theme and try (if there is an error in theme)
  3. rename .htaccess and param-link to default (page/post id)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.