2

I have this issue, where I can't access the frontend without a blank page anymore. It drives me crazy.

The backend seems to be up just fine, but the frontend is white. When trying to chose another theme (twentyten) this one also returns white, already in the preview.

I've turned on debug in wp-config after following another thread and it has come up with the following errors:

Warning: include_once(/home/dali/public_html/wilds/wp-content/plugins/wp-super-cache/wp-cache-phase1.php): failed to open stream: Permission denied in /home/wildsofo/public_html/wp-content/advanced-cache.php on line 14

Warning: include_once(): Failed opening '/home/dali/public_html/wilds/wp-content/plugins/wp-super-cache/wp-cache-phase1.php' for inclusion (include_path='.:/opt/php54/lib/php') in /home/wildsofo/public_html/wp-content/advanced-cache.php on line 14

What can I possibly do?

Website: wildsofoldham.co.uk

  • Do you have super cache plugin in plugins folder ? – Sumit Apr 2 '16 at 9:03
2

I wouldn't delete the htaccess. Just rename it for testing. (don't do this first though)

To find out what your error is though do this:

Turn on debugging in your wp-config.php file. Do this by changing this line:

define('WP_DEBUG', false);

to this:

define('WP_DEBUG', true);

Hit save.

Load the front page and you should now see the actual error. Use this to fix the problem.

If you can't resolve it this way, disable plugins by renaming the plugins folder to something else. Does your site load now? If it does, change the plugins back to "plugins" and deactivate all your plugins in the dashboard. Re-enable them 1 by 1 until you find the trouble-causing one.

Feel free to change the wp-config back once you're done testing.

2

In my case, nothing about debugging and disabling themes/plugins was useful... After some research, I've realized that my index.php was empty!
The only content was a message saying Silence is golden.
Using a backup I had, I could get back my original index.php and get the site working again.

1

I would try the following:

  1. Try to disable the wp-super-cache plugin or delete it completely through ftp.

  2. Delete the .htaccess located within root

  3. Check the wp-config.php for any line which is not a WordPress default and comment out.

  4. Go to admin > Settings > Permalinks > save once**

At this moment the front end should be visible.

If still not working, check with the server errors log which should reveal the exact problem.

0

If all else fails, check that your server is actually loading index.php as the priority.In my case, I was moving a WordPress site to a new server, I hadn't noticed that there was a default.html file in the root directory that, under the new server, prioritized loading default.html over index.php. There were no error logs, even loading index.php didn't work since WordPress automatically redirects index.php to mysite.com/, which would load the empty default.html file.

To ensure index.php is loading before others, add this line to your .htaccess file in the same directory as your Wordpress installation's index.php.

DirectoryIndex index.php index.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.