0

How can I prevent "nofollow" from being added to my internal links on bbPress posts? (I have the latest version of bbPress and WordPress)

The "nofollow" attribute is being added to my internal links on my website (DCJTech.info). However, this issue only occurs on bbPress posts, but not WordPress pages. Here is an example of the problem (bbPress post) – http://dcjtech.info/topic/general-unixoid-topics/

I have tried commenting out the below lines from ./includes/core/filters.php, but without success. I also cleared the cache (server and browser) and waited a minute before checking the page's source code.

add_filter( 'bbp_get_reply_content', 'bbp_rel_nofollow', 50 ); add_filter( 'bbp_get_topic_content', 'bbp_rel_nofollow', 50 );

I used 'grep -r -e "follow" ./plugins' to find all code that may be inserting "nofollow", and I also searched my theme and mu-plugins. In addition, I searched my SQL database (via phpMyAdmin) for "follow". I did not find any plugin, setting, etc. that could be causing this problem. There were no "nofollow" attributes in the posts either. I also searched my plugins for "bbp_rel_nofollow".

I disabled "External Links" and commented out the previously mentioned bbPress code (and cleared the cache), but the "nofollow" attribute was still on my internal links.

I thoroughly checked the WordPress codex website, forums (like https://bbpress.org/forums/topic/turning-no-follow-links-to-do-follow/ ), etc., but I cannot find a solution or cause.

0

As a temporary (but poor fix) the below code can be added to "functions.php".

//Remove nofollow function rm_nofollow($txt){ $txt=str_replace(' rel="nofollow"','',$txt); return $txt; } add_filter('bbp_get_topic_content','rm_nofollow',20); add_filter('bbp_get_reply_content','rm_nofollow',20);

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.