0

I have comments enabled under the "Discussion" settings (http://postimg.org/image/pvc3cb8yp/). However, every new post has comments turned off by default (http://postimg.org/image/ivagy6uuv/). When I do check off the box to allow comments, it does display the comments on the front end.

I don't have any commenting plugins enabled. Everything is up-to-date.

How can I resolve this issue?

0

You can try the following function:

function enable_comments() {
    update_option( 'default_comment_status', 'open' );
}
add_action( 'after_setup_theme', 'enable_comments' );

This should enable comments for all new posts. On the other hand have you checked your theme? Some themes for some reasons have build in functions that overrides the default WP comments behavior.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.