0

I'm trying to allow comments on WordPress pages, but when I check the page's "Allow Comments" meta checkbox option ( https://i.stack.imgur.com/P5Mbt.png ) and save page, it does NOT save settings, it returns to an UNCHECKED box again! Don't know why?!

My default discussion settings as the following: https://i.stack.imgur.com/5rxmn.png

PS: it works well on POSTS, but PAGES does not!

Any ideas about how to fix that?

Thanks in advance!

4
  • WordPress version is 4.1.1
    – Homer
    Feb 25, 2015 at 3:43
  • Activate one of default themes (like Twenty Fifteen) and try to save that option. You will know if it is a theme-related issue. If it is, you should contact with theme support. Feb 25, 2015 at 10:09
  • Thanks @macemmek, yes it was theme-related issue, I've contacted them, but I'm a web developer, so I may can fix it myself, if you can guide me to file/function.
    – Homer
    Feb 26, 2015 at 6:03
  • You may start by searching for "comment_status" string within theme files in order to see if any operations are performed on it. Feb 26, 2015 at 10:50

1 Answer 1

0

Thanks to the theme developers for helping me fixing it.

I'm posting the answer here in hope that it may helpes any person facing the same problem.

In functions.php there was a code to disable comments on page.php

Remove this part of code from functions.php to make the comments working on pages too:

    function default_comments_off( $data ) {
    if( $data['post_type'] == 'page') {
    $data['comment_status'] = 0;
    }

    return $data;
    }
    add_filter( 'wp_insert_post_data', 'default_comments_off' ); 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.