I am trying to change wordpress to Spanish. Including the admin.

I went to my wp-config and defined the value i.e. define ('WPLANG', ‘es_MX’); I went to the settings -> general and set the language to es_MX I went to the update screen to change the language

This is what I see:

If you need to re-install version 4.1–es_MX, you can do so here or download the package and re-install manually:

No matter how many times I update it doesn't work. What am I doing wrong? I even tried to upload the files in wp-content/languages from a downloaded version to force this update. Nope. Nada. Zip. Zero.


1 Answer 1


I found the issue. So what happens is that when you do redownload the wordpress you need to go BACK into settings and update the language setting in the dropdown. It will have a new value there. :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.