0

running wp 3.9 fresh install

update - now all is fixed:

now - with the new values

magic_quotes_gpc    Off On
magic_quotes_runtime    Off On
magic_quotes_sybase Off Off

left is: local value right is: master value

all goes well - the broken admin area is gone --- all goes nicely

findings; on the page where I can configure the widgets I cannot get anything done. I cannot add widgets and I do not know why.

i finally runned the wp-file-permissions-check

that is derived from that url https://wordpress.org/plugins/wp-file-permission-check/

get back the following errors:

Error: SplFileInfo::getPerms() [splfileinfo.getperms]: open_basedir restriction in effect. 
File(/home/vhost/WWW/literaturen.org/..) is not within the allowed path(s): 
(/home/vhost/WWW/literaturen.org/:/usr/local/httpd/icons/:/usr/local/httpd/phptmp/) 

how to treat this finding - what does this tell us!?

I am thinking that due to the permissions, the proper jQuery files for the WordPress core are not being loaded and thus breaking the admin backend. Switching the theme and turning off all of the plugins still causes the issues, so it is most likely that. another thought: probalby a jQuery library is missing, has been replaced, or is somehow different from the version

update

here the values of open_basedir according the php-ini - as it shows the current settings of the server:

**open_basedir**   
**local value**: /home/vhost/WWW/literaturen.org/:/usr/local/httpd/icons/:/usr/local/httpd/phptmp/   
**master value**: /usr/local/httpd/docroot

and i guess that this can cause lots of issues and confusion - what do you say!?

explanation: The open_basedir setting is primarily used to prevent PHP scripts for a particular user from accessing files in another user's account. So usually, any files in your own account should be readable by your own scripts. end of update:!

see the errors:

  • cannot configure the widgets
  • cannot access the set-options-page
  • cannot switch the accessible-mode -(in the set options-page)

I have the following errors in the firebug console:

POST http://literaturen.org/wp-admin/admin-ajax.php

200 OK
        1,39s   
jquery...=1.11.0 (Zeile 4)
GET http://fls-eu.amazon.de/1/batch/1/OE/A1PA6795UKM...26pc0%3D831%26ld0%3D831%26t0%3D1399322099520:831

204 No Content
        197ms   
csm-ba..._V1_.js (Zeile 232)
Content Security Policy: Ungültige Quelle chrome-extension://lifbcibllhkdhoafpjfnlhfpfgnpldfl kann nicht verarbeitet werden
Content Security Policy: Unbekannte Quelle chrome-extension://lifbcibllhkdhoafpjfnlhfpfgnpldfl konnte nicht verarbeitet werden

Given URL is not permitted by the application configuration.: One or more of the given URLs is not allowed by the 
App's settings.  It must match the Website URL or Canvas URL, or the domain must be a subdomain of one of the App's domains.

ping?c...dk=joey (Zeile 1)

and the following errors:

SyntaxError: illegal character

!function(a,b){\"object\"==typeof module&&\"object\"==typeof module.exports

    load-s...ver=3.9 (Zeile 2, Spalte 15)
SyntaxError: illegal character

...c,d){var f;return f=c&&c.hasOwnProperty(\"constructor\")?c.constructor:function(...

load-s...ver=3.9 (Zeile 1, Spalte 60)
ReferenceError: jQuery is not defined

})( jQuery );

customize.php (Zeile 560)
ReferenceError: jQuery is not defined

jQuery(document).ready(function()

what do you say!? it might be possible that the errors steem form the wrong openbase-dir!?

0

You can check for details on open_basedir in PHP documentation. Your issues very well might be caused by it. Despite that scripts and styles are typically not affected by PHP settings, in case of WP admin by default they are loaded through PHP script for concatenation.

It is hard to guess what and how exactly goes wrong without discovering details of that configuration and debugging through specific pieces that are failing.

  • hello dear Rarst - many many thanks for all! Happy to hear from you. I update my values that i found in the php-info. I will digg deeper and will contact my server-admin later tonight. ... again thanks for alll you did!!- Youre great! – zero May 7 '14 at 17:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.