I have a wordpress http site which still works just fine. I added https and the first page works but none of the post pages do.

server: Ubuntu 10.04.4 LTS (lucid) running Apache 2.2.14 SSL through RapidSSL

** EDIT **

Here's the 404 I see instead of a post (make note, on the exact url but with https I'm able to see my content)

Not Found

The requested URL /shortcuts/ was not found on this server.

Apache/2.2.14 (Ubuntu) Server at www.mydomain.com Port 443

  • 1
    What exactly do you see on the other post pages? Mar 31, 2014 at 18:34
  • I made an edit to the original question and added the apache 404 error page I see instead of the content.
    – Jacksonkr
    Mar 31, 2014 at 19:09
  • At first glance this seems like a permalink problem. Mar 31, 2014 at 19:12
  • Do you use Shared SSL? Mar 31, 2014 at 19:16
  • if by shared SSL you mean multiple virtual hosts using SSL then yes. differing domains though, with different certs. I saw this all as a potential htaccess issue, but yeah.
    – Jacksonkr
    Apr 1, 2014 at 0:28

1 Answer 1


My best educated guess is to perform a checklist on the following:

  • Take a look at the virtual host configuration files for your domains, if you have access to them. Ensure that they agree with the corresponding WordPress installations on your machine(s).
  • If your Virtual Host configurations are written correctly and as intended, then the next step is to check if your websites work with "Pretty Links" disabled. If they do, then we know for a fact that WordPress is probably configured incorrectly for using SSL, and that the URL Rewriting settings need to be changed for WordPress. The easiest way to do that is through the use of this plugin:

Potential Resources:

  • Problem was in the VHost config. Changed AllowOverride from None to All in two spots and viola. This makes it so your .htaccess files will be read. None will ignore your .htaccess files.
    – Jacksonkr
    Apr 7, 2014 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.