1

After I moved to a new VPS (Ubuntu), I can't update the WordPress. When I click on the "Update Now" button, it shows upgrading progress messages and it shows "Welcome to WordPress 3.9" (Now I'm on 3.8.3), but after refresh the page, nothing happens. Again, I'm on the WordPress 3.8.3.

Then I deactivated all the plugins and again, I re-update the Wordpress. But nothing happened. I can only fix this issue after reboot the VPS. After the reboot VPS, when I log-in/visit the WP dashboard, it only shows upgrade message. However I can successful update plugins without rebooting.

My VPS running nginx, APC, pagespeed mod, Ubuntu 12.04.

What could be the reason for this matter?

Thanks!

0

PHP's opcache module causes this kind of behaviour.

Disable this module by editing the file at /etc/php5/mods-available/opcache.ini and placing a semicolon like this.

;zend_extension=opcache.so

And restart PHP5-FPM/web server service.

If you are not comfortable editing these files add these lines to the top of your child theme's functions.php file.

if ( is_admin() ):
    ini_set( "opcache.enable", "0" );
endif;
  • Thanks A,Jesin. This VPS doesn't installed opcache. It only has APC. – Chathu Apr 18 '14 at 11:40
  • @Chathu APC has a apc.stat configuration directive which if set to 1 checks if a file has been modified before serving it from cache. Setting it to 0 improves performance but causes this kind of behaviour. Edit apc.ini which is found inside /etc/php5 and add/modify apc.stat = 1. – A.Jesin Apr 19 '14 at 9:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.