0

I moved my WordPress installation from my local dev environment (MAMP) to a shared hosting server. Since then I have trouble with image uploads not being processes as before, especially with the large size.

The large media setting is being ignored as long as I don't set it to quite small sizes. I want it to be at

Max Width: 940  Max Height: 10000 (or 0, I tried both) 

Once I go under 1000 with the max height, the large image is being created, if I go higher it skips that. I already added

define( 'WP_MEMORY_LIMIT', '256M' );

in the wp-config.php, and when I run phpinfo on the server is says

memory_limit    256M    

Any ideas what to tweak? I searched but coulnd't find something related. Thanks for replies!

  • 1
    What is the size of the original image(s) you're trying to upload? – Chip Bennett Apr 14 '14 at 17:28
  • ~2000px x 6000px @ 72DPI, RGB. I also tried an image which worked fine with the local setup, but it didn't work on the shared hosting environment (pretty default hostgator). – psteinweber Apr 15 '14 at 16:17
1

0 should work as a height in your thumbnail settings. The only other issue is that your uploaded images might be smaller than the large media size you're inputting. Image thumbs won't be scaled up for obvious reasons.

If your images are larger than your thumbnail setting and you're still not seeing thumbnails generated then:

  1. Check your server logs
  2. Try Force Regenerate Thumbnails
  • My images are way larger than the "large" media size (~2000px x 6000px @ 72DPI). Regenerating the thumbnails worked. But it's more a workaround than a solution I guess. Where would I typically find the server logs? I checked the "Error Log" in CPanel but it's empty. Thanks! – psteinweber Apr 15 '14 at 16:15
  • Contact your host and ask them where they store their PHP logs. If you change the thumbnail size then the new size thumbnails will be generated for new uploads only. In other words, WordPress does not go back through your media library and regenerate all your thumbnails, that's why you need to regenerate them. New image uploads should automatically resize to the new dimensions. – cfx Apr 15 '14 at 20:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.