Any time I create a new site on my multisite install, I get an infinite loop redirect when navigating to that site's admin. I'm using the default htaccess supplied by WP for my subdirectory install. Here's what I have:

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) site/$2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ site/$2 [L]
RewriteRule . index.php [L]

FYI - My wp install is within a folder named 'site', and the issue is happening both on my local mamp install and on my hosting server.

Here's the multisite info from my config file:

define( 'WP_ALLOW_MULTISITE', true );
define('MULTISITE', true);
define('SUBDOMAIN_INSTALL', false);
define('PATH_CURRENT_SITE', '/site/');
define('SITE_ID_CURRENT_SITE', 1);
define('BLOG_ID_CURRENT_SITE', 1);

I've spent the past 2 days googling, but to no avail. Here are a couple of solutions I've tried that didn't help:

Any help would be appreciated. I'm starting to get desperate :-/

2 Answers 2


I'm in a similar process and so far the redirects work fine for me. Maybe have a look at the following issue Changing subdir multisite install to subdir core directory structure and see how they resolved it.


Try installing the Better HTTP Redirects plugin and enable wp_debug in your wp_config.php file. This plugin interupts any redirects WordPress performs and gives you a stack trace of the last function called before the redirect so you can trace down what is causing the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.