2

Recently i have install a wordpress multi-site for a client.
After the initial launch client had change mind to transfer the site to a another domain, i have moved the WP multi-site successfully, i have no issue on front end, it's working fine i can access site 1 and site 2.

My issue is in back-end, when i access wp-admin dashboard under my-site, when i try access site1 and site2 dashboard my url is not changing, simply dash board not moving, the url for the site1 dashboard and site2 dashboard keep stay same, when i check the my sql table for site1 and site2 "siteurl" they are not reflecting home url for the sub site running in sub directory mode. when i change them manually they it worked, i could access dashboards of site1 and site2, but when i update site1 or site2 the url get reset again on site-url on sql database on site1 and site2, which i couldn't access again.

i have De-activate plugins to find the root for the issue, no results soo far, and i'm running the standard .htaccess as below

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
RewriteRule . index.php [L]

Below my wp-config settings

define('MULTISITE', true);
define('SUBDOMAIN_INSTALL', false);
define('DOMAIN_CURRENT_SITE', 'dhaman.net/ar');
define('PATH_CURRENT_SITE', '/');
define('SITE_ID_CURRENT_SITE', 1);
define('BLOG_ID_CURRENT_SITE', 2);

and my site url are

http://dhaman.net/ar
http://dhaman.net/en

Any body can shed some light on this matter, how to stop the site-url getting change in site1 and site2 sql databse

  • Has this question been resolved? – Ethan Jinks O'Sullivan Aug 28 '16 at 3:25
  • This question been resolved – Roshan Deshapriya Sep 5 '16 at 11:43
  • Glad that you solved your answer, did you do something similar to my answer below? If now, may you post your answer on how you solved this question? This was you can mark it as resolved and if the next person has a similar issue, they will know what to do. – Ethan Jinks O'Sullivan Sep 5 '16 at 12:20
0

Per the OP's comment:

I found trailing slash is missing is wp_options table in SQL, which is showing two blog sites running as multisite. Fixed the trailing slash site pointing correctly.

  • I found trailing slash is missing is wp-options table in sql, which showing 2 blog sites running as multi site, fix the trailing slash site pointing correctly. – Roshan Deshapriya Sep 6 '16 at 6:53
  • @rosh8111 Updated my answer per your solution. Please click the checkmark next to my answer to indicate that your question has been resolved. – Ethan Jinks O'Sullivan Sep 6 '16 at 11:52
0

You do not need to change any line of codes.

Solution:

You can use this plugin "Search & Replace" to replace the wrong url.

Example: there is button link in the site2 site which is "http://example.com/site1/somemenulink"

then in the site2 page "example.com/site2/wp-admin/tools.php?page=search-replace"

Step 1: Enter Search for field as 'site1' and enter Replace with as 'site2'

Step 2: Check "Export SQL file or write changes to DB?" as Save changes to Database

You are done!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.