1

I have just setup a fresh Centos server onto which I have installed the latest version of Wordpress. I then enabled multisite and went through and changed my .htaccess and wp-config as shown. I then logged out and back in again but there is not any My Sites menu at the top on the dashboard.

I have tried clearing my cache and on several different browser so I am pretty certain that it is a server issue.

This is the relevant part from wp-config:

/* Multisite */
define('WP_ALLOW_MULTISITE', true);
define('MULTISITE', true);
define('SUBDOMAIN_INSTALL', false);
define('DOMAIN_CURRENT_SITE', 'test.site.com');
define('PATH_CURRENT_SITE', '/');
define('SITE_ID_CURRENT_SITE', 1);
define('BLOG_ID_CURRENT_SITE', 1);

And this is the .htaccess

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
RewriteRule . index.php [L]

Can anyone see any issues or suggest where I might look next?

4
  • 1
    Do you have any sites to list? Or just the root site? What's listed in the sites section of the network admin? ( not all sites on a network are listed in my sites, they're specific to you the user, not the install )
    – Tom J Nowell
    Feb 28, 2014 at 17:40
  • @TomJNowell that's my point - there isn't a sites section. It's as if MU hasn't been enabled. But if I try to create a new one it says "An existing WordPress network was detected." So something is not right somewhere.
    – williamsdb
    Feb 28, 2014 at 18:12
  • 2
    Then you are clearly looking at the admin interface, not the network admin interface. go to /wp-admin/network and tell us what you see ( you will need super admin privilleges to do so ). Be sure that you followed all the instructions in the correct order. Simply copy pasting a full set of multisite defines into a wp-config.php of a single site will not give you a multisite, and misses out important steps inbetween
    – Tom J Nowell
    Feb 28, 2014 at 19:04
  • @TomJNowell aware of all that as I have done an install successfully a number of times. Anyway, I deleted the install and started again and it has worked this time - thanks for your help though.
    – williamsdb
    Mar 1, 2014 at 16:21

1 Answer 1

2

When you edit wp-config.php the second time - when the installer tells you to update your wp-config.php file with a bunch of multisite-related includes - at this point remove the definition for WP_ALLOW_MULTISITE.

REMOVE this line: define('WP_ALLOW_MULTISITE', true);

based on your example above, you'd be left with:

/* Multisite */
define('WP_ALLOW_MULTISITE', true);
define('MULTISITE', true);
define('SUBDOMAIN_INSTALL', false);
define('DOMAIN_CURRENT_SITE', 'test.site.com');
define('PATH_CURRENT_SITE', '/');
define('SITE_ID_CURRENT_SITE', 1);
define('BLOG_ID_CURRENT_SITE', 1);

Once I did that, I logged back in and suddenly the "My sites" menu appeared!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.