0

On the Plugins screen I have options to activate and deactivate plugins, but I no longer have the "Delete" option. I'm relatively sure the option appeared earlier.

Also, when I hover over "Plugins" on the admin menu I don't get the usual popup submenu showing "Install New / Add / Editor". And when I click the Plugins menu I don't see those submenu options either.

What's gone wrong?

FWIW, the client I'm working for is hosted at GoDaddy.

enter image description here

  • Are you running a single WordPress site, or a WordPress network? What is the user role for your current user? – Chip Bennett May 10 '13 at 19:32
  • 1
    Excellent deletion candidate. :D And thanks for sharing your aha moment. We need more of this. – fuxia May 10 '13 at 20:25
  • @chip-bennett This is a single, self-hosted WordPress site on GoDaddy, and the user is an Admin. – Andy Giesler May 11 '13 at 0:27
3

D'oh.

I fixed it, but I'll leave this question in case others have similar problems.

When copy/pasting various options into wp-config.php I accidentally included this setting, which I don't normally use:

// Overkill but FYI: disallows installation/updating of any theme or plugin
define('DISALLOW_FILE_MODS',true);

That produces the described problem, albeit by design.

| improve this answer | |
1

This help me a lot, actually I had 2 options active on my wp-config (never added them)

define('DISALLOW_FILE_EDIT', true);
define('DISALLOW_FILE_MODS', true);

just set the mode to false and problem solve itself...

| improve this answer | |
0

5 years after but I guess I´ll add my 2 cents. Don´t choose the plugin option on the left bar menu. instead, go to the top left on your screen and hover on my sites and on that sub-menu then hover on network admin and choose plugins there. Once that is done you will get the missing sub menu option to add new and the delete option will also become available once again on the activate, deactivate sub menu as well. cheers

| improve this answer | |
0

This helped me. Somehow it was there and i have never put it myself.

Change define('DISALLOW_FILE_MODS',true); to define('DISALLOW_FILE_MODS',false );

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.