2

I recently installed WordPress on my own server, which uses non-port 80 Apache service. I could view posts but the tinymce editor constantly broke. More specifically, all menu items in visual editor did not appear and if there were any text, they were all invisible until I highlighted them.

After numerous research, someone mentioned this problem could due to there is ":" (colon) in the siteurl address. I could not verify this theory because my ISP blocked port 80. I was wondering if anyone experience the same problem and how do they solve it?

  • 1
    Open the dev tools/inspector and look at your console. If it is indeed a port 80 issue you should have failure to load errors – Tom J Nowell Aug 27 '12 at 0:25
  • 1
    Also you would be better off using shared hosting rather than hosting a website from a home computer. If you have a limited number of people to share with, consider a virtual LAN – Tom J Nowell Aug 27 '12 at 0:26
  • Thanks, by opening up the debug console, I was able to figure out the path got mess up. I'm experimenting with Wordpress, I think in a while, if I do like it, I'll move to a shared hosting to make it look better. – Patrick Aug 28 '12 at 3:37
3

I had exactly same issue with Visual Editor but my site was working on port 80. This is what I did : Edited wp-config.php and added the following :

define( 'CONCATENATE_SCRIPTS', false );

and everything worked fine. Additionally you can check if wp-includes/js/tinymce/wp-tinymce.js.gz file exists or not. If not, then upload it via FTP

  • How do you know! I think all the problems (including plugin not loading properly are all related to the path not being set correctly. I was lazy and just perform a soft link to /usr/share/wordpress, which oddly created a lot of weird linking problems... I downloaded the stand along package from wordpress.org and copy the wp-config.php, everything begin to work!Thanks – Patrick Aug 28 '12 at 3:36
0

Check your javascript console. If you see an error like:

post.php?post=2840&action=edit:2783 Uncaught ReferenceError: tinymce is not defined

then the loading of wp-tinymce.php failing. Because the editor hasn't loaded, it appear as if your text is white, or "invisible" in the editor. This can be worked-around by adding:

define('CONCATENATE_SCRIPTS', false);

( Per Tijmen above, or this )

I use WP Fastest Cache plugin which has it's own concatenation, so if I use that plugin, then I'm OK skipping the default WordPress concatenation.

The root problem, however, is that a request to:

/wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=4506-20170408

Is failing or receiving a 404. This could be due to a security restriction on your hosting or CDN.

  • Thanks for the edit Jack. Can you explain what changed? The answer mostly looks the same to me, are you following some kind of "standards" I should know about (like using "here" instead of the full link)? Did you like the answer? – Charlie Dalsass Jun 6 '17 at 18:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.