I had to reboot my server due to recurring server errors (which I couldn't find a reason for). Since rebooting, echoing current_time( 'timestamp', true ) shows the time as 14 hours before my current timezone (GMT). As does echoing time(). However, if I go to “Settings > General” in WordPress, the correct time and timezone are showing.

This was all working perfectly before the reboot. How do I fix this? I have tried setting the PHP timezone via an .ini file, which made no difference. The server itself is showing the correct time.

1 Answer 1


true is for GMT time, try removing it.

current_time( 'timestamp' );


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.