0

I have a very strange issue that I am struggling to debug without amending the core function.

On page 1 of the blog archive it shows page numbers: 1, 2, 4 (page 3 is missing). On page 2 and 3 the pages numbering works fine but on the last page (page 4) I have a missing page again: 1, 3, 4 (page 2 is missing).

My blog is using the default page numbering function the_posts_pagination() I cant find anything that is overwriting this.

When I look at the HTML output I see the pages with missing numbers have the following markup where the markup for the page numbering should be.

<span class="page-numbers dots">…</span>

Can anyone assist on how I go about debugging this? I have spent hours looking at this and am getting nowhere.

Many thanks :)

2

This is the intended behaviour. If you have 200 pages, you generally don't want 200 links, so the function will display a few pages at the beginning, your current page and a couple of pages around it, and a few pages at the end. This is the default, if you were on page 50:

< Previous 1 ... 48 49 50 51 52 ... 200 Next >

This gives you a more manageable set of pagination links when there's a very large number of pages.

However, this behaviour is customisable by passing arguments to the_posts_pagination(). The specific arguments are described like this in the documentation for paginate_links(), which is used by the_posts_pagination():

If the ‘show_all’ argument is set to true, then it will show all of the pages instead of a short list of the pages near the current page. By default, the ‘show_all’ is set to false and controlled by the ‘end_size’ and ‘mid_size’ arguments. The ‘end_size’ argument is how many numbers on either the start and the end list edges, by default is 1. The ‘mid_size’ argument is how many numbers to either side of current page, but not including current page.

So you can control the number of links at the ends and in the middle like this:

<?php
the_posts_pagination(
    [
        'end_size' => 5,
        'mid_size' => 2,
    ]
);
?>

Which will give you:

< Previous 1 2 3 4 5 ... 48 49 50 51 52 ... 196 197 198 199 200 Next >

While you could use this to disable the behaviour completely:

<?php
the_posts_pagination(
    [
        'show_all' => true,
    ]
);
?>

Which would result in this monstrosity:

< Previous 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 Next >
| improve this answer | |
  • Ok thanks for the explanation but I only have 4 pages so this should not be happening and also there are no dots showing. The code for the dots is there but CSS hides it the class 'dots'. Therefore it looks like there are just missing numbers. I will put show_all true for now but its not ideal when the site grows and there are more pages :/ – LeeTee Feb 20 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.