0

So, let me clear everything at the start:

  • I'm not on shared hosting.
  • PHP upload limit is already set for 700mb.
  • PHP memory limit is set a 512mb.
  • Nginx, PHP-FPM and WordPress' logs tells me nothing about uploads at the time of uploads.
  • Restarting the server won't help.
  • Core WordPress has seen no updates, and plugin stayed the same. Thing changed there.
  • I do use a plugin to send files to S3, but deactivating it so the files stays on the local disk (which as plenty of space), I still get the HTTP error.

We've been uploading 100+mb files perfectly fine for ages. But this morning, trying to upload files that are more than ~5.5mb, I get the HTTP errors. If logs don't throw any errors, what is the else to do to debug those pesky HTTP error on file uploads?

  • You mention errors several times, but you never tell us what the errors are. It would be a lot easier to help, if we knew what errors you are receiving, and if there is more going on than simply uploading files. Is there a specific file type? Or, is this for anything, including basic TXT text files? Anything else you can tell us might be a big help in diagnosing this for you... – Mike Baxter Aug 27 '19 at 0:13
  • @MikeBaxter As far as error go, I don't know more. The only thing that WordPress spew is "HTTP Error", in small font around the upload form. (And like I said, nothing comes out in server logs, so really, I don't know what kind of errors). And as far as file types goes, it seems to be everything. I tried MP3, zips and images files (but did not want to create a 10mb txt files to test :P) Really, those are the only infos I could find myself. – Jean-Philippe Murray Aug 27 '19 at 0:32
0

This is the only article I could find that seems to address such a generic issue. They specifically talk about the generic "HTTP Error" message that you report.

Sorry! I know it is very frustrating.

Hope they have the answer you need!

| improve this answer | |
  • Sadly, they don't. Just the sake of keeping tabs on solutions, I'll adress them: error isn't temporary, it's be ongoing for the day; memory is set around 700mb, so this won't explain errors with 10 mb files; changing image library won't help because I get those errors with non-images files that won't go through GD or Imagemagick. I'll keep digging ! :( – Jean-Philippe Murray Aug 27 '19 at 0:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.