2

Recently, without changing anything on my website, Google search console started flagging 80 index coverage errors, shown as "Server error (5xx)". When I go look into it, what it's flagging are php files in the /wp-includes/ folder, which Google shouldn't be even trying to index. My xml sitemap doesn't include these files. I don't understand why google is trying to index and then flagging them.

Any ideas on why this is happening and what I can do to stop it?

  • 1
    The only reason Google would be trying to index a file is if there were a link to it somewhere. You shouldn't have any links to wp-includes anywhere, but you might if you have directory indexing enabled on your server. If you visit, in the browser, yourwebsite.com/wp-includes/ do you see a list of links to files and folders? You shouldn't. If you do contact your host and ask them to disable directory indexing on your account. – Jacob Peattie Jul 10 '18 at 12:19
  • Nah, .../wp-includes/ just brings up the 404 page, as it should. There's definitely no links to wp-includes anywhere on my site. I'll get in touch with my host to see what's up. – Jon Fergus Jul 11 '18 at 17:30
1

The cause is automatic indexes on folders on your server. For example https://www.yoursite.com/wp-includes/ shows an index of all the files in the folder.

The solution is to turn off indexes

add this to .htaccess

Options -Indexes

If you can’t do this then tell your host to disable indexes

| improve this answer | |
0

Check that wp-includes is excluded for index in robots.txt

User-agent: *
Disallow: /wp-admin/
Disallow: /wp-includes/
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.