Yes, i've seen some answers on different questions but they didn't fit to my situation.

My theme has title tag enabled.

The title in the wp_get_document_title() function is different than the real title in my Search Page, which is "You Searched For %search% - %site_name%".

I need to translate the title, nothing more. I searched for You Searched in functions_php and every other .php file in woocommerce that has product or search related and couldn't find it.

I would appreciate any help. Thanks !

  • Many different plugins and themes can affect these in various ways. It may have nothing to do with WooCommerce - check any SEO plugins you have installed or deactivate all plugins, check the page title, activate one plugin at a time, check the title, to determine which (if any) plugin is setting it.
    – WebElaine
    Oct 24 '17 at 19:26

In my case this problem was caused by Wordpress-Plugin Yoast Seo.

Take a look at your mySql-Database, Table wp_options and search for option_name = wpseo_titles

In the "option_value"-Field you can find the "You Searched for"-String and replace it by e.G. "Deine Suche nach"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.