0

When I just opened my site and started building, I deleted all of the default posts and pages, then I cleaned up the comments section, then I cleaned up the trash, everything was fine and empty.

Then all of a sudden there is a notification that says I have 1 approved comment, however the trash and the comments are empty and no comments show for me to remove them.

What does this mean? do I have to worry about a security breach or am I just being daft and missing something?

Here is an screenshot.

Any help would be greatly appreciated.

  • 2
    Can you provide a screenshot of this notification? Did you empty the trash of the comments and of the posts and of the pages? – Nikolay Jun 17 '17 at 10:18
  • I'd guess it's the example comment that had somehow survived the purge. Do you have database access - can you look in the wp_comments table? – Rup Jun 17 '17 at 10:43
  • My apologies, I can not figure out how to put a screenshot in here, I will re ask the question – That DJ Dude Jun 18 '17 at 11:29
  • @ThatDJDude I thought it is a new site with no content or plugins, but from the screenshot I see it has plugins. So it seems to me like a bug caused by plugins. Either there is some comment on some weird custom type page created by some plugin, or some plugin script bugged the counter, who knows... Try disabling all plugins and see if it is still there. To if there is an actual comment, you can go to the database via phpMyAdmin for example and go in your wp_comments table (you could have a different prefix than wp_). – Nikolay Jun 18 '17 at 15:35
  • @Nikolay Yes, you are correct, after I disabled ALL the plugins one by one, I figured out it was Woocommerce, but I still can't figure out why that happens or how to solve it – That DJ Dude Jun 19 '17 at 11:21
1

@Nikolay Yes well, I checked the database, there were no post, pages or products at the time, but then someone left a comment while I was testing with the "under construction" disabled, once I answered this comment everything turned out alright, the invisible comment was gone and now there are only the two comments, one by a visitor and one bt me, my friend said she had the same experience, I suspect its something with woocommerce, possibly the action button to set up the settings that keeps on reminding you, either way, its all fine and clean now, thank you so much for your assistance.

Regards Carl Stockigt

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.