0

I called my new home page "home" and it's permalink is website.com. In the reading settings, it set to a static page and the home page is set to "home".

I renamed the old home page to something new: "old home page" (its permalink is website.com/homepage3). When you type in website.com, I get an error:

"PAGE NOT FOUND STAY CALM AND DON'T FREAK OUT! Unfortunately, the page you are looking for is unavailable. Trying visit our Homepage and starting from there."

When you click on the "homepage" link in this message, it takes you to the correct, new home page.

Wordpress is telling me that the PHP is old. Could that be the cause of this?

  • In settings>reading, the page is set to static and the front page is set to "home", which is the current name of the page that I want to be the home page. – JulianJ Apr 16 '17 at 20:34
0

WordPress recommends using PHP 7 or greater. So if you are using an ancient version of PHP, you should upgrade your server.

After you changed the name of your home page, did you go back to your display settings and check what is set there? Make sure that it is set to the page you actually want for a homepage. (And be sure to set something for your "blog" page, as well.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.