1

All of the posts made within custom posttypes have suddenly become uneditable, and will 404 when you try to view them.Screenshot

The posts in the admin panel are greyed out (posts in the standard post/pages etc are fine).


Things I have Tried

  • I have tried using GIT BISECT but problem persists beyong where I know it to be working.
  • Tried downgrading wordpress
  • Checked various database elements such as post status and post author.
  • Tried setting and resetting permalinks.
  • Deactivated All plugins

New posts seem to be fine, and work normally. But my metaboxes have also vanished!! Again, GIT suggests this problem going back beyond where I know them to be working.

It seems, as GIT is incapable of finding the solution, that it must either be related to the database or the wordpress core itself (as my GIT repo only tracks the theme)

Wordpress is up to date.


Edit This is the function that creates the post types:

register_post_type($object_name,
        array(
            'labels' => mf_create_labels($object_name),
            'public' => true,
            'supports' => array('title','editor','thumbnail','page-attributes')         
        )
    );

using this to create labels:

function mf_create_labels($label){
    return array(
        'name' => __($label),
        'singular_name' => __($label),
        'add_new' => _x('Add New', $label),
        'add_new_item' => __('Add New '.$label),
        'edit_item' => __('Edit '.$label),
        'new_item' => __('New '.$label),
        'view_item' => __('View '.$label),
        'search_items' => __('Search '.$label),
        'not_found' =>  __('No ' . $label . ' found'),
        'not_found_in_trash' => __('No ' . $label . '  found in Trash'), 
        'parent_item_colon' => ''
    );
}

Update

I have got the meta boxes back, it seems Wordpress now insists on having the posttype declared in all lower case, despite be declaring the post types with capital letters


Please, if you have any idea where to look for the issue, comment. No suggestion too small at this stage

  • How did you create your custom post type? With a plugin or directly by inputing code into functions.php? – kevin Aug 2 '11 at 21:09
  • Using custom functions, which have not changed for long time prior to this issue. – Mild Fuzz Aug 2 '11 at 21:15
  • Do you use the 'rewrite' argument in your 'register_post_type' function? – kevin Aug 2 '11 at 21:20
  • I don't. I have updated my question to include the function I use. – Mild Fuzz Aug 2 '11 at 21:28
  • 1
    glad you solved it, your answer is good to know. – kevin Aug 3 '11 at 15:42
1

404's were being caused by problem with the WP Super Cache section in my .Htaccess file.

Greyed out areas AND metaboxes not showing up were being caused by Wordpress suddenly having a serious issue with using capitals at the start of Custom Post Type names.

Why these issues suddenly came to bite me? I have no idea!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.