0

I'm doing some work for a new client (non-tech, their former tech person left). Their version of Wordpress is 4.3.2.

The site gets some JavaScript errors on load.

Using the Console I noticed two plugin resources don't load throwing 404 (Not Found) errors:

/wp-content/plugins/embed_quicktime/jquery-1.2.1.pack.js
/wp-content/plugins/embed_quicktime/jquery.embedquicktime.js

However other plugin resources load like:

/wp-content/plugins/wp-greet-box/js/functions.js?ver=4.3.2

I looked in FTP and all the files and paths are definitely there.

Looking at the filesystem I don't see any permission differences on the folders or files.

I also noticed if I create /wp-content/plugins/wp-greet-box/js/test.html the file loads. it also loads when I create it at /wp-content/plugins/test.html however it 404s when I create it in /wp-content/plugins/embed_quicktime/

I also found when I create a new directory /wp-content/plugins/test/test.html the file is viewable on the website.

I tried renaming /wp-content/plugins/embed_quicktime/ to /wp-content/plugins/embed_quicktime-old/, creating a new folder /wp-content/plugins/embed_quicktime/ and putting test.html in there. However it 404d.

Somehow this WordPress installation is blocking access to the /wp-content/plugins/embed_quicktime/ directory.

I've searched through the database for the string embed_quicktime and also through the filesystem. The only database hit was the wp_options table (hits on these rows active_plugins, _transient_plugin_slugs, and _site_transient_update_plugins).

I feel like it must be set in the filesystem somewhere...

How do I diagnose this issue?

2
  • Did you check if those files exists?
    – Sisir
    Jan 22, 2016 at 14:21
  • Thanks for taking a look. Yes they exist. I also created a test.html file in each director. in the embed_quicktime test.html 404s and in the wp-greet-box it 200s. I also tested moving test.html up to /wp-content/ and it 200s there as well. Jan 22, 2016 at 14:24

1 Answer 1

2

I have the feeling that either those files don't exist or the location of the file has changed.

Go into /plugins/wp-greet-box/js/ and see if you can locate the functions.js and the jquery.js. If the files are not there then they must have been deleted and that is why it's throwing the 404 (Not found).

EDIT: Also I would remove some Plugins as a lot of Plugins can cause the page to load slow ect...

8
  • thanks for taking a look. The files are definitely there. WordPress is somehow blocking the /wp-content/plugins/embed_quicktime/ directory. I updated my question with additional information. Jan 22, 2016 at 14:40
  • Ar see I just thought they were missing xD Is that the only plugin you have? If not they one of the plugins might be blocking access and so on
    – Stephen
    Jan 22, 2016 at 14:48
  • @DavidSilvaSmith may I ask what Plugin your using as the embed quicktime plugin I found is outdated by 2 years so just make sure the plugin you have is compatible with the Latest Version of WordPress
    – Stephen
    Jan 22, 2016 at 14:53
  • That plugin is Embed QuickTime 1.1 by Andreas Haugstrup Pedersen. This install has 23 active plugins and about 5 related to embedding videos: DOP Player 1.0, EasyVideoPlayer 2.0 1.4.2, Embed QuickTime, Flash Video Player 5.0.4, and FV WordPress Flowplayer 6.0.4.6. I don't think all of them are being used but I don't want to remove any and break something (the site has over 300 pages) Jan 22, 2016 at 15:01
  • 1
    No problem xD Glad you found the course of it :) Best of luck with your site
    – Stephen
    Jan 23, 2016 at 1:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.