0

Recently I've configured SEO by Yoast for better On-page. But, after analyzing the SEO score and different aspects of it I found out that the template is considering General > Tagline as the Meta Description for the Home Page (I'm using Custom Page as an Home Page).

And for Post Template is considering initial line as the meta description for the post. How to fix this problem I've already tried contacting SEO Yoast support and template support but nothing happens.

0

Honestly, do not worry too much about Meta Descriptions too much. Search engines decides to show their own bits of meta description, based on Keyword Searches.

Make sure your content is perfected & is relevant.

Having said that, make sure:

  • You go Custom Page > Yoast SEO options > Meta Description & add your meta description for the page.

  • Go to Dashboard > SEO > Titles & Metas > General & ensure Force Rewrite Titles is checked.

  • Do not write any Meta Description for Post Template. Instead, add meta description from the Post Edit screen.

  • You go Custom Page > Yoast SEO options > Meta Description & add your meta description for the page. Already Did. All 3 steps checked. Can you verify that the issue has been resolved ? – P082 Sep 14 '15 at 3:23
  • The Meta Description is still not updated – P082 Sep 15 '15 at 3:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.