At first, my permalinks and all worked. My permalinks were in /year/month/post/ format. Today I found out when I try to open an Anspress question, I get a 404. (that worked too, last time I checked) Then I read somewhere I need permalink format of /postname/ to display Anspress questions.

So I changed it to /postname/. Now nothing except index.php?p=xyz is working. All links to pages throw a 404. I tried changing back to /year/month/post/ , but that did not help. Tried going to Permalinks and clicking "Save settings", but that did not help either. Tried a2enmod rewrite (although it has worked before), no help.

I have no idea. It worked 30 minutes ago.

2 Answers 2


i have also faced such kinds of problem when i upload the project to server and for fixed this i have followed below steps :

  1. change permalink and save it again. if code display below then replace with that code

  2. enable rewrite_mode and for doing this is have followed the steps from this article : https://anandnayi.wordpress.com/2015/07/04/404-not-found-apache-centos/


Fixed. Maybe an Apache update or something did this to me.

I changed AllowOverride None to AllowOverride All in /etc/apache2/apache2.conf for the /var/www folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.