1

I can't get the Featured Image metabox to show up on the edit page for the default post and page post types.

Though as opposed to this question, it does work for the custom post type I've created using a plugin. It just doesn't work with the default ones.

I've read the Codex Article on Post_thumbnails.

Added the following line to the current theme's functions.php and to that plugin I was working on:

add_theme_support( 'post-thumbnails', array( 'post', 'page' ) );

Also been checking the screen options on the top right of the edit page and the checkbox for the Featured Image is not even there.

Where do I check to see if something else does not overwrite that? Please help

  • 1
    By default post types "post" and "page" do have support for featured image meta box. You don't need to add some thing in function.php for that. I would suggest try deactivating your plugins one by one and check if it gets back. – Mohammad Mursaleen Dec 20 '14 at 7:59
  • @MohammadMursaleen thanks for reminding me about the disable-plugins approach, will see if that makes a difference and update the question – aexl Dec 22 '14 at 21:18
  • @MohammadMursaleen that was it, thank you. If you post that as an answer, I'll be happy to accept it. – aexl Dec 23 '14 at 18:59
2

By default post types "post" and "page" do have support for featured image meta box. You don't need to add some thing in function.php for that. This might be happening due to some plugin confliction.

I would suggest try deactivating your plugins one by one and check if it gets back.

| improve this answer | |
  • It was a plugin issue indeed: my plugin had the following code add_theme_support( 'post-thumbnails', array( 'my_post_type' ) ); and it turns out this enabled the thumbs for that type only, removing the support from the others. The solution was to remove the second argument, i.e. add_theme_support( 'post-thumbnails' );, this enabled the pics everywhere. Accepting this answer because disabling the plugins was what I did to narrow down the issue. Thanks a lot @Mohammad – aexl Jan 14 '15 at 15:45
3
  1. You don't need to pass an array to the function if you want Post Thumbnails everywhere. Just pass the function without arguments:

    add_theme_support( 'post-thumbnails' );

  2. Maybe you just need to change the post options. On the top right corner of the "edit post/edit page" page you have a button called "Options". There you can choose different areas to show or hide. Did you hide the Featured Image Metabox by mistake?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.