0

I have a Wordpress multisite.

I would like to change the email address on the super admin account.

The current email address on the super admin account is no longer accessible.

I can change the Network Admin Email in Network Settings but if I try to change the super admin email in users > profile I get a message saying 'There is a pending change of your email'

Do I need access to the old email address on the super admin account to confirm the change of email address.

  • Why not do this through phpmyadmin or similar SQL editor? – GhostToast Nov 23 '14 at 18:56
  • Can I just change the value in phpMyAdmin without causing any problems in the front end – user668499 Nov 23 '14 at 19:54
1

The question is old. However, I would like to answer it in the most effective way, as it can help a lot of people.

You can change the email address on the super admin account through phpmyadmin. Follow these steps:

  1. Sign into your cPanel account, which is provided by your web hosting.
  2. Under database section, click on the phpMyAdmin icon.
  3. A new page will appear. From the left-hand sidebar, click on your database name.
  4. A list of database tables will be displayed. Click on wp_options.
  5. You will see a new page. Find "admin_email" under "option_name. You will see your current admin email address in the "option_value" column. Click on Edit.
  6. A white box containing your current email address will appear. Type your new email address. Finally, click on the Go button to save it. enter image description here

You will find more information about these steps right here. If you follow them accordingly, you will be able to change the email address on the super admin account successfully.

0

The network admin email is changed from wp_sitemeta table. Use following query in phpmyadmin or any mysql client in order to update the email if you are unable to change from network admin settings.

UPDATE `wp_sitemeta` SET `meta_value` = 'the_new_email@abc.com' WHERE `meta_value` = 'the_old_email@abc.com';

Note: please use the table prefix accordingly used in db if it is not wp in your case.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.