0

My code looks like this:

paginate_links( 
  array(
   'next_text' => __('>'), 
   'prev_text' => __('<'), 
   'base' => @add_query_arg('page', '%#%'), 
   'format' => '?page=%#%&a='.$a, 
   'total' => ceil($count/$per_page), 
   'current' => $page)
)

Everything works perfectly but if I click on for example second page my URL goes to www.domain.com/something/2/?a=5 instead of www.domain.com/something/?page=2&a=5

Is it possible to change it into www.domain.com/something/?page=2&a=5?

3
  • Please let us know what have you tried so far? Jan 23, 2014 at 16:40
  • I tried just that code you can see above, this worked for me on homepage but when I apply this on other page it doesn't work Jan 24, 2014 at 15:17
  • I think you want that WordPres don't use pretty permalinks for the pagination links. I think it is not possible. You can disable pretty permalinks in Settings->permalinks, but it a global option. I think that the only way to do it is writting your own pagination function.
    – cybmeta
    Dec 21, 2014 at 11:17

1 Answer 1

1

Change variable page to something else, page is a reserved keyword & whenever in url it found it convert url in to localhost/wordpress/page/2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.