2

I created a custom post type with a taxonomy defined, but I am having trouble getting an archive page to show up.

  1. I get a 404 page not found. The individual post shows up but nothing on archives page.

functions php.

function create_post_type() {  
    register_post_type( 'my_properties',  
        array(  
            'labels' => array(  
                'name' => __( 'Commercial Properties' ),  
                'singular_name' => __( 'My Property' )  
            ),  
        'public' => true,  
        'menu_position' => 5,  
        'rewrite' => array('slug' => 'Myproperties')  
        )  
    );  
}  

add_action( 'init', 'create_post_type' ); 

function property_taxonomy() {  
   register_taxonomy(  
    'properties',  
    'my_properties',  
    array(  
        'hierarchical' => true,  
        'label' => 'Category',  
        'query_var' => true,  
    )  
);  
}  

add_action( 'init', 'property_taxonomy' );  

I have tried:

• Creating an archive-my_properties.php (should the page be named after the registration or the slug? • Resaved permalinks • Flushed Rewrite rules

  • Please separate ACF issue into a separate question (if it would be in-scope for WPSE). – Chip Bennett Nov 12 '13 at 19:35
2

You need to declare 'has_archive' => true in the arguments array you pass to register_post_type(). The default value is false, which means that WordPress does not generate an archive index for the post type.

  • 1
    good grief, tried everything except to see if the vcr was plugged in. – user31344 Nov 12 '13 at 19:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.