I'm on OSX 10.8.4 with a pretty standard installation of Wordpress 3.6.1 under the local OSX Apache/MySQL.

If my permalinks are set to /%category%/%postname%/ I get a 404...

This is working on the live server which I think is running CentOS, so it's definitely something wrong on my machine.

I don't have any custom post types. I am using the wp-no-category-base plugin, but removing that has no effect on the 404 problem.

Same problem using default theme.

/%category%/%year%/%postname%/ works, as does /%category%/%post_id%/%postname%/, although:

/%category%/%postname%/%post_id%/ puts the ID on the end of the URL twice...

Check out the config details I've got:

My mod_rewrite is on in httpd.conf (LoadModule rewrite_module libexec/apache2/mod_rewrite.so)

My .htaccess looks to be properly generated by Wordpress:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

And my httpd-vhosts.conf has the correct AllowOverride All lines in it (check out the commented lines for other things I've tried!):

<VirtualHost *:80>
    ServerName sitename.gareth.dev
    DocumentRoot /Users/G/Sites/SiteName
    DirectoryIndex index.html index.php

    <Directory /Users/G/Sites/SiteName>

        Options Indexes FollowSymlinks
        AllowOverride All

        # Options Indexes MultiViews SymLinksIfOwnerMatch
        # AllowOverride Options FileInfo

        Order allow,deny
        Allow from all
    </Directory>
</VirtualHost>

Any help would be very gratefully appreciated!

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.