1

I'm trying to upload a XML file through Wordpress Importer

It shows this error, no matter what the size of the file is.

Even 10kb file throws up this error.

My php.ini settings were set to 100MB, still no change. Back to defaults, wich is 8MB.

I'm starting to think it's permission related.

Any ideas?

  • Who is your host? Tried talking to them? When I have encountered permissions issues w/ WordPress on HostGator, there is a script they run to reset all of the permissions. Usually works pretty well. – GhostToast Jun 22 '13 at 14:38
  • I've talked to them yesterday, they couldn't solve it... They didn't reset the pemissions, but that's just a guess too – Lucas Bustamante Jun 22 '13 at 14:46
  • GoDaddy's respose: "Hmm, I'm really not sure why this is happening sir. All of the permissions look correct on your files, the php.ini is working normally" – Lucas Bustamante Jun 22 '13 at 16:20
  • Don't forget post_max_size should always be at least equal to upload_max_filesize. – TheDeadMedic Jun 23 '13 at 6:25
1

You need to make the following changes in php.ini file on your server.

upload_max_filesize = 100M
post_max_size = 100M

If still it's same then update value of memory_limit.

0

Use phpinfo() to verify what the setting is. Some hosts do not allow you to change the PHP settings via php.ini. Some may require that you do it via .htaccess. If when you run phpinfo() the value is different than the 100MB you set it to via php.ini then there's a good chance this is the case.

Look through your host's knowledge base or give them a call and they can tell you their preferred method of changing PHP settings. Also, some hosts do not allow you to change certain settings in which case you'll need to request that they make the change. They will be able to tell you this as well.

Hope this helps!

  • According to phpinfo upload_max_filesize is 100MB – Lucas Bustamante Jun 22 '13 at 15:35
  • @user2056484 What is the value of post_max_size ? – tacudtap Jun 22 '13 at 17:27
  • 8MB (filling this space to fit the minimum characters to send this message) – Lucas Bustamante Jun 22 '13 at 21:08
  • @user2056484 Hmmm... I was thinking if it was lower than 10kB then that would be your problem because as TheDeadMedic mentioned above post_max_size should at least be the same as upload_max_filesize. Where is the php.ini that you changed located? Root? Check to see if you have one in wp-admin. This one would override the other and is where you would want to make your changes. – tacudtap Jun 24 '13 at 13:39

protected by Community Jan 14 '17 at 13:00

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.