I have an old RHEL Workstation site, running the latest wordpress version 3.5.1.

I have a newer CentOS 6.4 site, running the latest wordpess version 3.5.1.

I have added the Wordpress import plugin tool into the new site successfully.

I have exported the entire blog from the older wordpress site successfully.

I have attempted to import the resulting xml file, but it appears not to succeed, but without any errors or explanation.

The import appears to start successfully after pressing the button for uploading and importing, after the .xml file is selected, and I see some activity. However, the Import page goes blank, and there are no errors or any other kind of message.

The blog is still usable; that is nothing has frozen.

What do I need to do to import properly?

  • 1
    Is debugging enabled?
    – s_ha_dum
    Commented Jun 19, 2013 at 19:25
  • Did you check your logs?
    – kaiser
    Commented Jun 19, 2013 at 21:08
  • Which logs should be checked? I did grep /var/log, and how do you enable debugging for wordpress? Commented Jun 20, 2013 at 13:13

3 Answers 3


A lot of people (including myself) have experienced random issues like you describe with this latest version of the WordPress Importer plugin.

I recommend using WP Migrate DB. This plugin will not only migrate your content, but allow you to optionally find/replace any serialized URLs (in the event you're migrating to a different domain as well).

  • +1 on WP Migrate DB, we use it for all site transfers that are moving servers. Commented Jun 19, 2013 at 20:23
  • @AndrewBartel I also recently purchased a license for their pro version. If you develop locally, stage, and then deploy to production with multiple environments you might like it! I love it because it'll push/pull data right from the admin, along with saving push/pull profiles on a per-installation basis. It's a huge time saver.
    – Jared Cobb
    Commented Jun 19, 2013 at 20:42
  • I ran the sql created on my new database, and my blog won't come up. mysql < sql-created-by-migrate-db.sql . There is just a blank page. I'll go back to scratch, given there's nothing yet important in the blog. Commented Jun 20, 2013 at 13:48
  • I'm back to a blank, newly installed blog. Commented Jun 20, 2013 at 14:27

Here is what I did to fix the problem.

I looked at an export of the old blog after wordpress, php, and apache had all been upgraded.

I looked at an export of the mostly blank new blog (on the recently installed CentOS 6.4 system).

I made the title and other fields look the same for the first few lines in the xml file to be imported from the older blog.

Most of the XML required no editing.

Everything updated just fine after that.


The same problem was here with me on my website i tried lot a lot of plugings but but at the end i used Jetpact Sitemap. This is working great and also supports the Google News as well sitemap.xml file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.