Twice I installed a fresh LEMP Ubuntu 12.04 instalation on my server and started to build a wordpress site on my VPS following This tutorial. Now, for the second time, after a while I can't write do anything (write posts, update configurations, etc) because I get timeouts.

My resources are: 512 mb Ram, 1 CPU and 20gb of SSD. I'm running on Ditital Ocean.

I tried to fix it but couldn't find any similar issues around, but I suspect the problem has to do with the database because I can still update plugins, which does only add files to the folders that already exists.

The weird thing is that both times I had everything working perfectly and all of a sudden I started to get these problems. Last time the site even stopped working and the screen only showed that the site was Temporarily Unavailable.

Do you know what can have happend to get to this stage? Thank you!

  • What do your logs say? Honestly, 512MB RAM for a production server seems way too low. I suspect you are having memory issues. – s_ha_dum Jun 14 '13 at 14:50
  • Hi @s_ha_dum , Thank you for your comment. I checked and it's alrigh, both on iostat and htop there are plenty of free space. – André Lucas Jun 15 '13 at 5:12

512MB should be fine, especially if you just started building your site.

I've ran single WP installs on DigitalOcean droplets with 512MB of RAM without any issues in the past, also on NginX. Obviously, server stability also greatly depends on how NginX, MySQL etc have been configured (ie. not to consume too much memory and such)

Have you installed any security-related plugins? On what DO zone are you? From personal experience, they are having issues with some hypervisors on the Amsterdam zone currently.

If you are somewhat inexperienced related to sysadmin-tasks, try downloading an SFTP client such as BitVise Tunnelier to login to your droplet, visually browse through folders and grab/download log files on your computer for further analysis.

Assuming you have not modified the default log locations, you should be able to find relevant logs in or at: /var/log/nginx, /var/log/mysql, /var/log/mysql.err, /var/log/mysql.log

Edit: I found this for you: https://groups.drupal.org/node/218439

Disregard the fact that it appears to be Drupal related, the problem you're mentioning might be related to a faulty php-fpm config.

Another possibility I think might be incorrect Nginx permalink rewrite rules.

Are you able to paste here/upload on pastie.org your NginX config file(s) ? Feel free to redact your IP/domain name.

  • Thank you very mych , @jakker ! That was a good explanation! Well, one thing I did before was to follow this: rtcamp.com/wordpress-nginx/tutorials/single-site/w3-total-cache w3tc explanation and setup. As it was the only thing that might have gone wrong, I got my nginx permalinks reconfigured to what it was before and the system got back to normal after a few minutes and a refresh. I tried to look at the log files and system stats and nothing was wrong (iostat and htop). Probably was that configuration to cache things (although free memory was ok)! Thank you again! – André Lucas Jun 15 '13 at 5:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.