0

After installing the Jetpack plugin, the visual editor stopped working. The Visual tab is still there but the editor area is empty and the toolbar is missing.

I have deactivated all other plugins and the problem is still present. (The only other one was Restricted Site Access). Disabling Jetpack (or disconnecting it from Wordpress.com) fixes the problem, but I would like to use some functionality from Jetpack.

Has anyone else seen this problem, and is there a fix? Is it a particular Jetpack configuration that causes this? I saw several complaints online, but not fixes.

  • 1
    I had the same problem and it's the short code module that causes the problem... I'll contact the jetpack support to see how they can deal with it. Hope this will help someone else as well ! Cheers ! – user48988 Mar 14 '14 at 19:04
1

I just had the same problem using Jetpack v3.3 on http://ataxproforyou.com. I deactivated the whole jetpack plugin and the features came back, reactivated the plugin and was fine, until I connected it to my wordpress site http://ataxproforyou.wordpress.com and they went away again. I deactivated spell-check setting but that didn't resolve. I deactivated the Shortcode Embed feature and then it was functioning again.

FYI - this still causes problems in future releases but try deactivating the shortcode embed feature and that should resolve the problem.

  • Does the issue return if you reenable the Shortcode module? – Ryan Jan 6 '15 at 22:14
  • Haven't tried...don't use the shortcode feature. And if it ain't broke.... – Sebastian Mealer Jan 11 '15 at 4:02
0

Finally this was solved by disabling some Jetpack modules. I am not sure which one did it, but I suspect the spell checker.

To disable a Jetpack module, go to the Jetpack page on the dashboard, then click "Learn More" on a module. The "Configure" button changes to "Deactivate", so now you can disable the module. (This seems a bit counterintuitive and difficult to find.)

I hope this will help someone else too, as I noticed several people were complaining about the problems on various forums.

-1

go to wp-admin/admin.php?page=jetpack_modules disable Shortcode Embeds model this will work

  • 1
    Please try to add a bit more to this answer. – s_ha_dum Nov 24 '15 at 20:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.