Hot answers tagged

12

jQuery / JavaScript in the footer One thing you can do is to move jQuery to the footer blog post. It's per default not needed in the header. You will have check if everything still works tough, as I normally just do that for themes: <?php /* Plugin Name: Move jQuery to the footer */ function( 'admin_enqueue_scripts', function( $hook ) { $GLOBALS['...


7

The proxy settings work just like a regular HTTP requests but in this case obviously routed through a proxy. In terms of WordPress the API's transport layers all support proxy connections(fsockopen, fopen, cURL, ). The things about proxy configurations are they come in several flavors and each setup is different so it makes answering this difficult, it ...


4

I recommend installing this https://github.com/johnbillion/query-monitor and looking at the following: Memory usage, HTTP requests, AJAX and slow queries. It could be your revisions, a plugin's AJAX, a bad query, etc. You will be able to see if you need to add more RAM to your server which usually solves a lot of slow loading admin issues, especially if ...


3

Along with some of the well suggested answers above you could limit or disable wordpress "heartbeat" which can dramatically slow down your admin if you have a lot of screens open or many users using at once. Several hosts like WP-Engine actually have a variation of this setup automatically. function optimize_heartbeat_settings( $settings ) { $settings['...


2

Please take a look at Administation Over SSL, particularly the "Using a Reverse Proxy" section.


2

Changing proxy_set_header Host $host; to proxy_set_header Host $http_host; fixed the issue. (source)


2

I created simillar configuration to yours and proxy is working for me. My config looks like: Host production HostName xxx.xxx.xxx.xxx ProxyCommand ssh -q -W %h:22 vagrant ForwardAgent yes Host vagrant HostName 127.0.0.1 User vagrant Port 2222 UserKnownHostsFile /dev/null StrictHostKeyChecking no PasswordAuthentication no IdentityFile /...


2

Using a proxy is important when you cannot store your authentication credentials securely. One encounters this problem when building single page applications with client-side JavaScript Frameworks like Angular or Ember. This blog entry by Alex Bilbie nicely summarises the issue. As a side project, involving a Angular/Ionic/Cordova application and WordPress, ...


2

If it's browser cache, you can go into the dev tools and disable all local cache. Browser docs can tell you how to do this. If it's the proxy cache, either turn it off or load the site without the proxy, and retest. You will need to consult the documentation for the proxy you're using for how to do this, and how to fix it. You would be better asking on ...


1

Not sure if this helps, but you can try.. So WordPress' default HTTP transport is using cURL, and the HTTP class sets the proxy authorization method to CURLAUTH_ANY (see source), which might explain why the Proxy-Authorization: Basic xxxxx... header is missing from the request. And there's a hook you can try to change the proxy authorization method to ...


1

Why would you even want n automatic update in such a setting? bit orgs rarely allow just random software being installed without testing it first. In any case, this is unlikely to be achievable in a sane way unless you limit yourself only to plugins from the wordpress.org repository as any "pro" type of plugin and theme will require making more "holes" for ...


1

What about using a Force SSL plugin like this one?


1

Remove all of the force SSL plugins that you're running, revert back to your default settings in the wp-config.php and .htaccess before applying forces to use HTTPS. This will remove all of the conflicts you are having and the redirect loops. After that, follow these steps: Go and download Interconnect IT's Database Search & Replace Script here Unzip ...


1

Have you changed the "WordPress Address (URL)" and "Site Address (URL)" at Settings -> General on WP-Admin to from http to https? Flush the cache and check again? If there are still mixed protocols, it probably came from hardcoded url such as images and external links. You can leave it as is, or fix it. I gone through this when I switched to SSL, you can ...


1

If your AJAX is a 'post', or for that matter any protocol, to URL2PNG the client is doing so directly. The client isn't aware of, nor would it honor you server's proxy configuration. Considering the brief read of URL2PNG docs, placing your API key and password in your JavaScript/jQuery is risky at best since you'd be exposing that information to any site ...


1

I was having this same issue. We were using Apache as the proxy (ProxyPass & ProxyPassReverse defined) and the simple addition of the following to the virtual host resolved it: Add to the virtual host: ProxyPreserveHost on


Only top voted, non community-wiki answers of a minimum length are eligible