Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange
4

The basic idea should work-- change the prefix in both wp-config.php and in the database itself. What isn't covered would be cases where the prefix is used in other contexts such as when used as part of a "meta" key. Those cases you would need to trace down one by one. You could also have trouble it the prefix has been hard-coded into anything, but ...


3

You can’t. WordPress tracks the recently active plugins for a while, but there is no history of deleted plugins. You could install a logger and track this information in a special place for the future.


3

Links: http://codex.wordpress.org/Hardening_WordPress http://perishablepress.com/press/tag/security/ (lots of great articles) http://www.wpsecure.net/secure-wordpress/


3

Depends on your business needs. If you're running it for a personal blog or a small site then stay away from suspicious plugins and hosting providers and you'll be fine. There are some good security/backup plugins which tend to sometimes work. The best advice though is "stay updated" ;) If you're doing something bigger then go for VaultPress (not free). If ...


2

1) See if the internal folder /theme is writable too. 2) Add define('FS_METHOD','direct'); to wp-config.php


2

your mistake is WP_CONTENT_URL's postfix. Because, you should use this definitions this type; define("COOKIE_DOMAIN", "www.artisanplombier-pascher.com"); define("WP_CONTENT_URL", "https://static.artisanplombier-pascher.com"); So, you should configure, your static. subdomain's path in your server's configuration file or your hosting's control panel (create ...


2

There could be any number of problems with your site, so it's really hard to say what the real "problem" is. I'd suggest first checking out your console for http request errors (see if there are any files not transferring), and also try logging in to see if anything changes. Based on what you're describing, though, it sounds like you're experiencing the ...


1

My similar issue was solved with wp core download --force --locale=de_DE wp core verify-checksums


1

I had forgotten to define the location of wp-content in my wp-config.php : define( 'WP_CONTENT_DIR', dirname(__FILE__) . '/wp-content' ); define( 'WP_CONTENT_URL', 'http://'.$_SERVER['SERVER_NAME'].'/wp-content' ); define( 'WP_PLUGIN_DIR', dirname(__FILE__) . '/wp-content/plugins' );


1

Supplementary to s_ha_dum's answer and the comments: The meta keys I needed to change when I did this (v4.8.5) - i.e. all wp_usermeta.meta_key entries beginning wp_, or whatever your current prefix is - were: _capabilities _dashboard_quick_press_last_post_id _media_library_mode _user_level _user-settings Symptoms: visiting /wp-admin/users.php and seeing ...


1

if you have a file at WP_CONTENT_DIR/install.php it will be run before the upgrade starts. If you want to override specific option then you can use the pre_update_option_$optionname filter to control the value written to the DB. something like add_filter('pre_update_option_admin_email','wpse_120475_myadminmail',10,2); function wpse_120475_myadminmail($...


1

I for instance have MAMP pro running with custom development URLs like project.dev. When I created the one-click installation of Wordpress through MAMP, it automaticly entered the port-number into Wordpress as well. I don't think Wordpress likes when the port-number is :80 which is standard. Removing the port-number from Wordpress Address and Site Address ...


1

I think this article will be spot on. Just found it tody :) http://wp.smashingmagazine.com/2011/11/10/securing-your-wordpress-website/ Here are some more links on the subject: http://codex.wordpress.org/Hardening_WordPress http://wp.tutsplus.com/tutorials/10-steps-to-securing-your-wordpress-installation/


1

Please clean your browser cache and try it again! Worked for me.


1

Try repairing the wp_options table, that solved the issue for me months ago. Also make sure the table prefix in wp-config.php is correct.


1

So many things you need to look at and they are not just to do with WordPress. Here is a video that I like about WordPress security as it mentions on of my plugins: http://wordpress.tv/2011/11/07/damian-taggart-wordpress-security-the-end-of-innocence/ Also there is a good book about WordPress security I recommend that I have read also: http://www.amazon.co....


Only top voted, non community-wiki answers of a minimum length are eligible