Questions tagged [troubleshooting]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
5
votes
3answers
464 views

Easy code troubleshooting in wordpress

Is there an easy and standard way to debug our code in wordpress plugins? I want to print some variables in a function that runs when a certain things happen. Is there a wordpress way to save this in ...
5
votes
3answers
6k views

Troubleshooting a Network site displaying a blank page [closed]

I have a Wordpress install in Network mode, with subdomains. sitex.example.com is displaying a white page, with nothing in the source code. Other network sites display fine. I renamed the theme the ...
4
votes
5answers
28k views

get_template_directory_uri() and other URL tags not working in theme

So, I'm trying to add get_template_directory_uri or bloginfo() to my header.php file to create relative paths for the CSS and JS files in the theme. E.g., <link rel="stylesheet" href="<?...
3
votes
2answers
2k views

Plugin screenshots not showing in the repository

I'm having major trouble getting the screenshots to show in my plugin. I have validated the readme file and placed the screenshots in both the /trunk and /tags/1.0 directories (1.0 is stable). I have ...
3
votes
2answers
19k views

W3 Total Cache active but not working [closed]

Update: Found the reason for the issue. The theme had this add_action('init','ezgz_buffer'); function ezgz_buffer() { ob_start('ob_gzhandler'); } The above code enables gzip-compression if the ...
3
votes
1answer
10k views

How to solve a conflict between a plugin and a theme?

I'm using Photospace as a gallery slider within my hatch pro wp theme (you can check here). The default transition effect between slides is a crossover effect (like this example), but the effect in ...
3
votes
2answers
3k views

Troubleshooting fetch_feed and SimplePie

I've got a very basic solution using fetch_feed() and SimplePie to pull in RSS items which is working on my localhost, but for some reason is_wp_error() persists as true on the live server. Is there ...
2
votes
1answer
3k views

Why is save_post hook not running?

I am trying to save my meta box, I have something like function xxx_meta_box_callback() { add_meta_box('xxx-meta', 'xxx Details', 'xxx_meta_box', 'xxx-post-type', 'side', 'default'); ...
2
votes
2answers
3k views

Forgot password not working

I have been trying to reset my admin password for my local install of wordpress running on MAMP. Previously had been working fine but I forgot the password but when I go through the process of 'Lost ...
2
votes
2answers
773 views

Widgets not expanding on wordpress 3.3 widget dashbord

I updated to WordPress 3.3 (manual update) and cleaned browser cache. Widgets dashbord stop working when tring to expand dynamic sidebars for custom theme when it works for previous wordpress 3.2 ...
1
vote
3answers
176 views

Copying wordpress to another server breaks it on original server

I am working on a new version our site. Today I was going to put the blog on the new version. Our current website and the successor I am building are on different servers and accessed by different ...
1
vote
3answers
191 views

Find source of notice / warning / errors efficiently

While debugging plugins or themes I will often come across a notice / warning / error which doesn't really provide useful debugging info. Notice: get_current_site_name is deprecated since version 3.9....
1
vote
2answers
364 views

How do I change the description of the same image which is to be found in multiple instances?

We have the site from http://asceticexperience.com/ Feel free to dig the site in order to understand our question below. Of course, any feedback appreciated :-) but my main question is the following:...
1
vote
2answers
22k views

White Blank Page when Updating and Publishing Page/Post

I have a serious problem here, every time I publish and update a page/post it displays a white blank page.. here I don't know how to fix it.. is there anyone that can help me? Thanks :)
1
vote
1answer
675 views

Divi Child Theme not appearing in “Themes” [closed]

I've created a "divi-child" folder within the "/themes" directory of my site with the appropriate "style.css" and "functions.php" files within. Code for those files is below. Even with all of this in ...
1
vote
1answer
2k views

500 internal server error

I am facing 500.0 Internal server quite frequently with my website. The error details are given below. HTTP Error 500.0 - Internal Server Error C:\PHP\php-cgi.exe - The FastCGI process exceeded ...
1
vote
1answer
23 views

I just got my domain vsmathur.co.in verified by Google Domains, but cannot access my WordPress site, Help! [closed]

Folks, Just to give you a brief history, I have been running my WordPress site located at: http://vsmathur.co.in successfully till 10th of December, 2019. I was also able to access the /wp-admin. ...
1
vote
0answers
24 views

I got an issue after i migrated a site

I recently migrated a site to a larger server. Everything appears to be fine, the site works everything transferred over. The site does have an SSL cert. Recently we started to get flagged as unsafe ...
1
vote
0answers
95 views

Masonry images not working

Until yesterday, all 10 tiles were showing on the main page on this website. After updating 3-4 pages and adding a "blog" function to them (separated by category), only 3-6 tiles will show at any ...
1
vote
0answers
158 views

My Homepage Suddenly Disappeared and I Can't Get It Back

All of a sudden my website's homepage (a static page operating as my storefront) disappeared, and its now displaying a blog feed of the latest posts. If I click through on any of these posts in the ...
1
vote
0answers
16 views

Having wordpress page accesss issue under sub-directory

I have hosted website at sub-directory but pages content is not showing and only header and footer display at pages. My index file have this code for pages display. It was working fine at root ...
1
vote
1answer
72 views

Blog posts not displaying

on my Wordpress site on the first page I always get my posts displaying however when I navigate to my 'Blog' page with my blog template attached to it I cant get my posts to display here. I used a ...
1
vote
1answer
399 views

Post thumbnails not working in my new install of WP 3.1 with Twenty Ten theme

I am working in a new project, and I just realized that in the page/post edit pages, I don´t have the option to set a featured image/ post thumbnail. I have checked and Twenty Ten has thumbnails ...
0
votes
4answers
7k views

My Wordpress website was hacked [closed]

Today while working, I had tried to install Go Pricing Plugin from this website. https://www.downloadfreethemes.download/go-pricing-v3-3-8-wordpress-responsive-pricing-tables/ It was unsuccessful at ...
0
votes
1answer
998 views

long delay before loading website because of wp_footer()

This might sound weird but this is what really happening to my website. while investing the long delay even before my site starts to load, after searching the source of the problem for a long time i ...
0
votes
3answers
6k views

Debug 500 Internal Server Error on WordPress blog

My WordPress blog is hosted on a shared webserver on Hostgator. I've been having 500 Internal Server Errors the last couple of days. I haven't installed any new plugins since the errors started ...
0
votes
1answer
108 views

How to direct user after comment save

I've been trying to direct the user to the specific page after they posted the comment, but that not luck for me. Here is the my code blocks My first try: add_action('wp_insert_comment', array($...
0
votes
1answer
2k views

Text of posts is suddenly not visible anymore [closed]

(WordPress 3.8 running Twenty Eleven theme.) http://www.joyofdata.de/blog/ I just realized that neither on the Wordpress homepage nor after opening a post I can see any text. If I click on edit ...
0
votes
2answers
191 views

Why is Wordpress filtering Pastebin URL's

WordPress seems to be filtering Pastebin URLs. When attempting to include pastebin links into either new or pre-existing posts, the following error is returned: “Not Found” It seems most — if not ...
0
votes
1answer
67 views

How to troubleshoot WordPress issues? [duplicate]

Possible Duplicate: How do you debug plugins? I have an issue that the posts table shows "no posts found" right after the installation although I can see "All (1) | Published (1)" right above it. ...
0
votes
2answers
2k views

What is this error message?

After installing wordpress and some plugins i am getting this error when i create a sitemap. I realy have no idea what this is and how to solve. Any help would realy be appreciated! Warning: ...
0
votes
1answer
757 views

“Backdoor-list.txt” files unexpectedly in server

Furthermore, there are "bad-directory-permissions-list.... .txt"files. My website is currently under repair due to malicious code being found. Could this be part of it? Should I delete these files ...
0
votes
1answer
55 views

How to use page jumps to top of banner and page title?

I've tried using page jumps as instructed by countless websites to "jump to the top of my page": Source code followed by destination code: <a href="top_page">LINK TEXT HERE</a> <a id=...
0
votes
2answers
414 views

My WordPress install is not loading the admin styles

I'm having this problem where my WordPress install is not loading up any sort of clients scripts or styles, here is what the login form looks like: Any ideas on what's going on here? I've reinstalled ...
0
votes
1answer
512 views

Moving jQuery to footer from header

Here is my file. My wordpress is 4.5 =============================== FRONT-END ENQUEUE FUNCTIONS =============================== */ function sunset_load_scripts(){ wp_enqueue_style( 'bootstrap', ...
0
votes
1answer
2k views

I can't change permalink in Wordpress 4.5.3

I have trouble with my site. I use latest version of Wordpress, but when I try to change post permalink then I haven't any result. Change link dialog isn't showing. Simply nothing happens :( No errors,...
0
votes
3answers
199 views

Timezone Change Locked Me Out? [closed]

I have a weird issue: I changed my timezone, hit "Save," and was immediately logged out of the admin panel. Now every time I try to access the dashboard after logging in I'm immediately logged out. ...
0
votes
1answer
408 views

HTTP requests start hanging after I try activating all plugins, and only stop when I manually disable the plugins via DB

Basically, I've got a new dedicated server, and I'm testing the migration over to that server. The site (WordPress-based) seems to work fine, but I noticed that sometimes, I can put the server in a ...
0
votes
2answers
480 views

Parse error:syntax error [closed]

I'm new to Wordpress. I'm trying to create a Wordpress theme. But i am getting the error: Parse error: syntax error, unexpected 'meta' (T_STRING) in \xampp\htdocs\wordpress\wp-content\themes\theme\...
0
votes
1answer
90 views

<video> tags disappear on pages (but not on posts!)

I'm creating my first theme. If I add the following content to a post, the video displays fine on the site: <p style="text-align: center;"><video width="320" height="240" controls="...
0
votes
1answer
320 views

Wordpress wont startup

So far I've narrowed down the execution trail to index.php -> require('./wp-blog-header.php'); -> if ( !isset($wp_did_header) ) { require_once( dirname(__FILE__) . '/wp-load.php' ); -> if ( ...
0
votes
1answer
351 views

Menu not styling. New menus functionality giving me a headache

I can't find a good tutorial on the new menu handling functions, and the ones I found don't seem to work for me. What am I doing wrong? In my functions.php: (I'm using the Blank Slate theme as a ...
0
votes
1answer
2k views

Is “SELECT TOP 0” a bug with MS SQL database?

I'm having an issue that my posts page displays "no posts found" while right above it, there is "All (1) | Published (1)" (it is a new installation). The post is also invisible on the live site, not ...
0
votes
2answers
3k views

Why my theme option not working?

I am looking for the bugs about an hour but i can't find anything. Can you look and say why my theme option is not working? Problem: The theme option not saving. Even the default option is also blank....
0
votes
0answers
10 views

I updated my plugin and added a new tag (1.0.3). Readme in trunk & tag has “Stable tag: 1.0.3”. It's been weeks & my plugin hasn't updated

Any idea what this could be? I've definitely pushed the changes, as the README has updated to reflect in the changelog, but embarrassingly the WP page still says version: 1.0.2 and the plugin hasn't ...
0
votes
2answers
21 views

What do I do if my WordPress site is suddenly sanitizing portions of URLs it shouldn't?

Nobody has touched wp-admin for this site in weeks. Suddenly, URLs are being sanitized in ways that break everything. The question marks of query parameters are being replaced with URL escape code %3F,...
0
votes
1answer
21 views

HTTP 500 error when updating a page

We got a Wordpress site, designed by an external contractor a couple years ago. https://playbacktheatre.com.au We recently (Dec 2019) changed hosting providers in search of a better service. After ...
0
votes
2answers
73 views

Site downloads files instead of loading them

Until two days ago the site was working fine. Yesterday, I've done nothing to it and now when I try to go to the web site it downloads a file that contains: <?php /** * Front to the WordPress ...
0
votes
0answers
21 views

child theme result in blocked subnets

I've created a custom child theme. after activating the child theme, sucuri firewall plugin blocks continuously access to child themes style.css for each visitor which ends after some hits in banned ...
0
votes
1answer
142 views

Why is my WP site blocking my own IP?

Im stumped WP is hosted on a VPS Browser will not load anything curl returned connection refused SSH access to the VPS works UFW does not have any specific ip addresses blocked Apache logs do not ...