Questions tagged [collation]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
5
votes
2answers
5k views

How to stop WordPress using utf8mb4_unicode_520_ci collation?

Recently I've installed PHP7 on my MAMP and updated to newest version of WordPress. Every time I do a new site all my tables are using collation utf8mb4_unicode_520_ci I have tried setting define('...
6
votes
4answers
3k views

Default table collation on plugin activation?

I'm following this to make my plugin auto-create a table when the plugin is activated, but what happens is that while all the tables (the whole db) are utf8_general_ci, the newly created table is ...
1
vote
1answer
60 views

Hebrew Characters Have gone bad

I have read this question: I have tried the following: ALTER database mydbname CHARACTER SET utf8 COLLATE utf8_general_ci; ALTER table ext_hebrewText CHARACTER SET utf8 COLLATE utf8_general_ci; ...
2
votes
1answer
367 views

DB_COLLATE not working on fresh install

I always knew that WordPress uses utf8_general_ci as tables collation, but recently it keeps installing utf8mb4_unicode_520_ci. What I do is: Download WordPress from wordpress.org Rename wp-config-...
1
vote
1answer
6k views

Unknown collation when I import a dump from an existing site into a development database?

I exported the sql from an existing database for an existing site that's hosted on Bluehost. I'd like to be able to import it into the development environment without hitting an issue; I'm flexible,...
10
votes
1answer
6k views

Please explain how Wordpress works with MySQL character set and collation at a low level

As the question title suggests, I'm looking to understand how Wordpress works with MySQL character sets and collation options. As I will show below, things don't make much sense to me... I installed ...
-1
votes
1answer
775 views

How to stop WordPress from using utf8mb4_unicode_ci collation

I'm using WP Sync DB plugin for migrating sites between dev, stage and live. Recently i ran in this problem: while creating a new instance on my local dev, WordPress created all tables with ...
0
votes
1answer
206 views

Wordpress character set issue

I'm currently migrating a wordpress site to a live server. When trying to import my database via phpMyAdmin I run across the following error below: Error CREATE TABLE `wp_commentmeta` ( `...
2
votes
0answers
1k views

Database with mixed collation (utf8mb4 & utf8_general_ci)

Each time I was uploading my WP install from offline to online, I was noticing strange characters in text and digging a bit I have discovered that wp-config.php on the online server was set to define('...
-1
votes
1answer
1k views

“Error 1064” when importing msql database after updating wordpress version to 4.2.1

I have a error in importing my sql file that contains the db of my site When i export from local, is ok my settings Server: mysql wampserver (127.0.0.1 via TCP/IP) Server type: MySQL Server version: ...
0
votes
2answers
3k views

How do I convert a MySQL database from utf8mb4 to utf8 encoding?

What happened: I had my blog hosted on SiteGround and my plan expired. I created a full website backup first which contained all the files including the public_html folder adn the databases associated ...
1
vote
1answer
464 views

database collation differences

I have a database for a site I am developing in WAMP. The collation for the database is latin1_swedish_ci but every table in the database is utf84mb_unicode_ci. Should I be worried about this? In ...
2
votes
1answer
454 views

Character Encoding for wp_options

I've been looking for a solution to my problem for a while now. Under my wp_options page I have the following serialized entry saved: a:17:{s:11:"date_format";s:5:"d/m/Y";s:15:"currency_symbol";s:1:"...
0
votes
1answer
125 views

Problem in adding new site on WP multisite

It's for two or three months that this problem exists in WordPress multisite and I'm still waiting for a solution or an update. When adding new site, I get this error: Warning: preg_match() ...
4
votes
2answers
220 views

One for the gurus: upgrade to 3.x messed up only filenames with accented chars

After upgrading from 2.8.x (maybe it was 2.9.x) to 3.1.2, all the references inside posts to filenames (usually images) which contain accented chars stopped working. Before, filenames that are ...