Questions tagged [bug]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
-1
votes
0answers
12 views

What is the problem of this code [closed]

<div class="container "> <div class="row"> <section> <div class="col-sm-8 main_site_article"> <div class=...
0
votes
1answer
681 views

The Commercial tab is missing from the Plugins page when trying to update Types 1.7

I have Types installed and registered on my live server, but also want to get it installed on my development server (which of course has a different URL so will have to be registered separately). ...
1
vote
2answers
646 views

Custom Menu Broken WP 3.8.1 Update

Custom menu has stopped working since upgrading to 3.8.1. When trying to add items from the left they do not show up as movable items as they should do under Menu 1, however the text changes to: "Drag ...
3
votes
1answer
738 views

Why is wordpress removing some unicode characters (e.g. some emojis) when I save my post?

Try making a new post, pasting this string of emojis: "πŸ»πŸπŸ¦πŸˆπŸ”πŸ„πŸ¦€πŸ•πŸ¬πŸ˜πŸŸπŸΈπŸπŸŽπŸ’πŸΌπŸ–πŸ‘πŸŸπŸ’πŸ³" and then saving that post as a draft. When I do this (in WP version 4.7.4), it removes the emojis. ...
1
vote
1answer
34 views

Default image size not working

I have some hooks on my WordPress Theme in order to customize the default images sizes, but it does not work. Here is the code: function my_custom_image_size() { add_image_size( 'post_size', 730);...
0
votes
0answers
34 views

The editor has encountered an unexpected error. Shortcut key to duplicate Ctrl+Shift+D breaks gutenberg

whenever I try to use the shortcut key to duplicate Ctrl+Shift+D , wordpress gutenberg editor just errors out β€œThe editor has encountered an unexpected error” Please help, its very hard to write ...
0
votes
0answers
13 views

A bug happens in the Footer and the code keeps appearing

On this WordPress site with the Newspaper theme, the footer appears and looks normal (as you can see in https://www.vendaonline.pt/), but I installed a question plugin (DW Question Answer) and on the ...
0
votes
1answer
945 views

How to Fix WordPress Not Saving Settings?

How Can I Manually Fix & What is The Root Cause? The Site Language setting in Settings > General for my site, will not update. It is stuck on English (United States). I have done all the ...
0
votes
1answer
461 views

Undeletable posts, users or other content

Recently I tried to move a WordPress instance to a production server and (besides other issues) had to deal with a page that could not be deleted via the admin panel. The success message would show up ...
1
vote
1answer
101 views

How can you receive the most recent permalink or terms of the newly saved post?

When using the Gutenberg Block Editor the normal hooks for saving a post don't have the same behavior as with the classic editor. pre_post_update save_post wp_insert_post For example, if you hook ...
38
votes
8answers
20k views

Sending multipart (text/html) emails via wp_mail() will likely get your domain banned

Summary Because of a bug in WP Core, sending multipart emails (html/text) with wp_mail() (to reduce chance of emails ending up in spam folders) will ironically result with your domain being blocked ...
0
votes
0answers
32 views

Media Dialog CSS broken in WP v.5.3.2

My plugin displays the media picker dialog on the users front end. If a user has WordPress 5.2.2 installed then the media picker dialog looks nice/normal (see the first image). If they have WordPress ...
0
votes
2answers
1k views

Icons are missing from Visual Editor

The Problem I've been grappling with this bug over several days now to no luck. When editing either a post or a page, all icons in the Visual Editor are missing: As you can see this, includes the ...
0
votes
0answers
21 views

Editing Pages Icons Are Not Showing Up - Why is this happening?

https://prnt.sc/pgoou9 - check it out https://prnt.sc/pgop70 - here too. https://prnt.sc/pgopeo - however putting the mouse above them shows their function but still... How can we fix this situation, ...
1
vote
1answer
25 views

Url having # at end [closed]

Sir , I have a e-commerce website on wordpress. After everything done from my backend I started testing website on mobile devices but sir my website pages urls are not refreshing properly. One ...
2
votes
1answer
97 views

How can I set status='publish' for all featured images?

Background: I've come accross this WP issue: https://core.trac.wordpress.org/ticket/41445 In short: when you make a request to a post over the REST API, if the featured image was originally uploaded ...
0
votes
1answer
18 views

Password not resetting on wordpress?

I've repeatedly tried to reset my password on the Wordpress site according to their help site but it never changes despite not throwing an error. Attempting to reset my password through the 'forgot ...
0
votes
0answers
27 views

Login issue in Wordpress

I'm facing currently an issue with my wordpress site, i don't know exactly what happened but when i try to login from /wp-admin i enter my password and i connect, but naturaly after the session dies i ...
1
vote
1answer
24 views

Is there a way to append meta data without creating a race condition?

Our site has a lengthy AJAX function that appends content to the user's cart, which is stored as an array in the usermeta table. The function looks something like this: $cart = get_user_meta($userID,...
1
vote
1answer
3k views

Password Protected page not asking for a password

I have set a page to be password protected in the admin, but for some reason WP is not asking for the password when viewing the page. It definitely isn't a plugin as I have confirmed the behaviour ...
0
votes
0answers
53 views

Multi line of $wpdb->query just run 1 time and end the loop right after

<?php foreach ( $posts_array as $post ) { $post_id = wp_insert_post($post,true); //var_dump($post); $wpdb->query($wpdb->prepare("UPDATE wp_posts SET VenueLongitude = '$...
0
votes
1answer
152 views

Product slider not showing when clicking on tabs

I'm in need of some specific help with my Wordpress webshop of the Blaszok MPC theme. The website can be found at http://testsite.vansompel.be The problem is situated when scrolling down to the tab '...
1
vote
0answers
22 views

Wordpress site periodically goes down

my site https://mediatrends.me/ periodically goes down. It works fine and then all of a sudden any page becomes unreachable in every web browser. "site can't be reached", etc. After a few minutes it ...
0
votes
1answer
45 views

How can I stop 'in use' message from intermittently blocking my wp_posts table?

How can I stop the 'in use' message from intermittently occurring in phpMyAdmin wp_posts table? I have no warnings and no error messages prior, but when it happens to my wp_posts table, all my ...
1
vote
1answer
295 views

WP not logging in at first time

I've been experiencing a weird "bug" in my website which I have a form in the front page to do the log in, it doesn't log, redirects me to the WP-login.php and it says the Cookies may not be active in ...
2
votes
1answer
924 views

Wordpress gallery previous/next buttons showing all media library images

I have just noticed that on my installation of wordpress, within the gallery image pages, the previous/next buttons are browsing through my entire media library rather than just those images that are ...
0
votes
1answer
148 views

Why is switching between themes breaking my child theme?

I am working on a child theme that I am building on top of twentyseventeen. Everything was displaying as intended within my page templates. However, if I switch between my theme to another and then ...
0
votes
1answer
510 views

Woocommerce categories displayed on every category and shopping page

Since we updated to the latest version of woocommerce today we've been having a problem. On every category page and shop page it displays all of the main categories (not the sub categories) we have on ...
-1
votes
1answer
399 views

Disable PAGESPEED SCRIPT INJECTION to IMAGE in theme files [closed]

Since a few days I am bugged with INJECTION of PAGESPEED scripts for every image all across my theme files, and it just messes up the code (though it doesn't break the site). I want this to be ...
0
votes
0answers
34 views

WP Dashboard -> Posts-> Filter > BUG!

I've a problem in the Posts List in the Doashboard. When I filter (by POST) the Posts the results aren't the same than to pass the category slug by GET. Here the examples: Can you help me? Where is ...
8
votes
2answers
1k views

Uploaded images don't show in Media Library if there are special characters in IPTC Keywords

Some images that are uploaded to WordPress don't show up in the Media Library. The images get uploaded and even cropped to the defined sizes, there is an entry in the Media Library, but the preview ...
1
vote
1answer
1k views

Adminbar Missing “Edit Page”

I'm encountering a problem that involves that my Admin bar doesn't show the "Edit Page" on pages I visit on my site. Instead for some odd reason it show "Edit Category" instead on supposed page. Does ...
0
votes
1answer
29 views

Title tag wont change

I changed the Title of the Blog, in the Customizer and everywhere else i checked the title, it changed, except on the actual site. I already checked, if the tag is set static in the header.php, its ...
1
vote
0answers
44 views

Trying to Edit a Page but it sends me to a Product Edit page

I have the strangest issue that I encountered. I have updated the newest version of Wordpress and installed Google Analytics GADWP Plugin and Yoast SEO. (I don't think this is the issue though) When ...
0
votes
2answers
322 views

Meta Query doesn't works as espected

i have a little big problem with meta queries. I Designed a query to retrieve posts where any of these words exists in the custom field pickup_address. the field has this string in its meta value: 43 ...
1
vote
4answers
177 views

WordPress Odd migration issue

I migrated my WordPress install and DB to another server (same domain). And I am getting this: Also everything is where it should be (including file and db permissions and other specific settings): ...
3
votes
1answer
3k views

Add Media has stopped working in the front end since 4.5 update

I've got a page that calls wp_editor in the front end. Since upgrading to 4.5, the Add Media button no longer does anything at all. It works fine if you call it in the admin section. There's no word ...
3
votes
1answer
169 views

Bug in Stackoverflow styled badge system script

I have modified an old Stackoverflow inspired badge system script to work with the latest Wordpress version. You can view the code here (and please feel free to use it if you wish). It has a ...
-2
votes
2answers
865 views

Paste Function Broken

My paste function appears to be broken for my Wordpress site. I have tried on multiple computers, and browsers, and the results are the same: I cannot post anything, whether it be text, an image, or ...
0
votes
1answer
803 views

Add post overwriting permalink from previous post in 4.6

Since updating to 4.6, I've noticed that if I add a second post shortly after the first, I'm overwriting the first post. The editor is blank, but permalink is the pre-existing post. I simply have no ...
0
votes
0answers
41 views

Site has fake users registered with a similar pattern in username and email

Website keeps getting hundred of fake users. Registration form has reCaptcha but no effect. By changing required fields in form to add First Name and Last Name required still fake users keep getting ...
4
votes
3answers
5k views

Dashboard says “no posts found” even though there are some posts

I have a weird bug on the dashboard: the dashboard says there are a total of 3 posts, but the list is empty and says "No posts found" (see image below) It's a fresh install on a shared Windows ...
0
votes
1answer
54 views

Meta key in wp_query bug?

$query_args = array( 'post_type' => 'post', 'posts_per_page' => 6, 'order'=> 'desc', 'orderby' => 'meta_value date', 'paged' => $paged ); This is my current query to sort posts. What ...
0
votes
1answer
109 views

Cannot use old slug - it just 301s to site home page

Thanks in advance for any help guys, For some reason my three pages stopped working, they just 301 to the home page. I think it may of been due to installing a plugin but I am not entirely sure. I ...
0
votes
1answer
218 views

Wordpress Visual Editor is not working

From 2-3 days, Wordpress Visual text editor is not working. I cannot type anything, cannot press any button. Nothing is working in the "Visual" section. But "Text" (html) editor is working perfectly. ...
0
votes
1answer
45 views

How to link file or image from wordpress plugin dir to theme by using themes function.php, is it possible?

I have some image file in my plugin directory. I want to display those file by using my theme function. I am trying many way but something was wrong. Theme and plugin both dir is loaded at same time. ...
1
vote
1answer
1k views

Woocommerce: custom loop in product tabs breaks reviews tab

I came across a weird issue, not sure whether it's a bug or something is wrong with my code. Woocommerce allows to show cross-sale products only in the cart by default, so I had to make a custom loop ...
-2
votes
1answer
8k views

Suddenly, all links in #content div are not clickable, but I don't see any z-index bug? [closed]

Following a bunch of seemingly harmless plugin updates, I suddenly have a weird bug. All of the links in my #content section are now unclickable, although the links in my sidebar, header, footer, etc....
6
votes
1answer
1k views

Images all broken after migration and upgrade

I have upgraded a neglected Wordpress installation the was a few versions off. After the installation and upgrading multiple version, all of my images are now broken which were not before. Whenever ...
0
votes
0answers
181 views

WordPress 4.4.2, _s starter theme, problems with custom default header

I'm using the _s starter theme and setting up a custom header image. I've got this code: add_theme_support( 'custom-header', apply_filters( 'xyztheme_custom_header_args', array( 'default-image' ...