For some reason the PrettyPhoto script that WooCommerce is now using is adding #prettyPhoto to the end of URL's once it's been opened in that page.

See here for an example

Also, when you close the lightbox down it takes 2 or 3 clicks of the back button to get back to where you were previously.

Anyone have any idea why?

1 Answer 1


That is a … feature of this script, called deeplinking. It should be fixed already, maybe you missed an update?

As you can see in that commit, you can disable it by editing assets/js/prettyPhoto/jquery.prettyPhoto.init.js. Add

deeplinking: false

… to all calls of prettyPhoto({});.

  • You're right, I didn't realise there was an update available! Apr 30, 2013 at 22:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.