-1

I was able to share links from my WordPress blog on Facebook with no issues up till about a month ago. Previously, the abstract and featured image turned up fine, but now only the link shows up. I've tried adding OG meta tags to my functions.php but it is not solving the problem. Using a plugin didn't help either.

I ran the facebook object debugger and I got a response code: 200 Error:

Can't Download: Could not retrieve data from URL.

Here is a sample link.

  • 1
    Your page took a minute and a half to fully load, it appears linkwithin's widget.js is delaying page load for some reason, I suggest disabling that and testing again. – Milo Apr 28 '13 at 16:44
  • Hi Milo, thanks for the suggestion. I disabled it but it still doesn't solve the link problem on facebook. The site does load alot faster though. – Theresa Apr 29 '13 at 0:18
0

I finally solved it. It was something with the permalinks. I changed the permalinks structure and suddenly it works.

For anyone who may have a similar problem, try going to settings under wordpress --> permalinks and try changing the permalink structure. I changed mine from day and name to post name and now facebook can recognise the links.

protected by Community Dec 17 '18 at 8:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.