1

Every time I insert an image into my post, the default link is to the image attachment page. How can I change it so it always links to the File address?

7

Answered a similar question on the .org forums very recently.

To sum it up though..

  1. Go to http://example.com/wp-admin/options.php (replace example.com with your website address)
  2. Scroll down the page until you see image_default_link_type
  3. Set that option to either file, post or to an empty value.

Empty = No link
File = Links to the file(what you asked for)
Post = Links to the attachment page(default)

Hope that helps.. :)

  • Note: You'll need to scroll to the bottom of the page and click save after making the appropriate change. – t31os Jan 28 '14 at 15:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.