0

i wanted to make an offline copy of my live website on my pc so i installed xamp and installed on it wordpress and exported the database and took a copy of files on fttp and after i have done eveything and i wanted to make open my live website to edit something it gives me a blank page when i open

 "www.sitename.com/wp-admin" 

but when i open

"www.sitename.com/wp-login.php"

it open put when i insert username and password it also gives me blank page

i opened the wp-config and i found that dp host became "localhost" i think this is my problem but how can i get my dbhost back is there a way to find it

closed as too localized by fuxia Apr 25 '13 at 10:38

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • localhost is probably the correct setting, if the database is on the same server as the web server. Check the error logs on the web server for any errors. try setting WP_DEBUG to true in you wp_config.php file and check if you get any error output in the browser. – windyjonas Apr 25 '13 at 8:52
  • ok it gave me error Warning: Cannot modify header information – sarah Apr 25 '13 at 9:03
  • @sarah In wp-config.php file remove all spaces before "<?php" and after "?>" – dipali Apr 25 '13 at 9:20
0

i found the problem there was space in function.php

-1

Add this code to theme's functions.php file

add_action('init', 'clear_buffer_output');
function clear_buffer_output() {
        ob_start();
}
  • 1
    Please: NO. That could hide the problem; it is not a solution. And without an explanation, this isn’t even an answer. – fuxia Apr 25 '13 at 9:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.