So I pulled a site down to my local machine to do some work on it. Copied the files, find/replace on the database to update the url, added a host. Everything worked fine until I changed the permalink settings. Now every page uses the index.php template in my theme folder instead of the page.php. Of course it works fine when you use the default settings, but not any others that require htaccess directives. I have tried everything I can think of including changing the AllowOverride None to All in the httpd.conf.

Anyone else have any ideas? I am at a complete and frustrated loss.

Edit: Here is my htaccess file:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
# END WordPress
  • Is WP attempting to write to htaccess? That is, does it report that it does not have permission to do so?
    – vancoder
    Apr 23, 2013 at 16:36
  • No. It has writing permissions. It is writing to it just fine. I will post my htaccess file.
    – BobbyDank
    Apr 23, 2013 at 16:40
  • 1
    Is htaccess being parsed at all? IE, if you deliberately put some junk in there, do you get an Internal Server Error?
    – vancoder
    Apr 23, 2013 at 16:45
  • Yep. If I rename the file, I get a 404 error. Otherwise, pages default to index.php. Posts and my custom content type (which is a post) do not. They use their correct templates. It is just pages that are the problem. They don't see any page templates.
    – BobbyDank
    Apr 23, 2013 at 16:50
  • So permalinks for posts work? Your htaccess looks fine. Try switching to a standard template and see if the problem persists. Do you have a caching plugin active?
    – vancoder
    Apr 23, 2013 at 17:24

1 Answer 1


Okay. I got it working now. Turns out it was one or both of my custom taxonomies I had added on with my custom content type. I knew it had to do with my custom content types or taxonomies because, if I took them out and reset the permalinks, everything worked fine.

The names for these two taxonomies where type and year. I simply changed the names to media_type and media_year and everything is humming along just fine now. I guess Wordpress uses certain names and you have to be careful what you use because it can break everything.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.