-1

When I try to view/access my blog I get the following message....

Just wondering if anyone has any ideas as to the cause and the solution?

Warning: require(/home/photogian/room2850.com/wp-includes/post-template.php) [function.require]: failed to open stream: Permission denied in /home/photogian/room2850.com/wp-settings.php on line 119

Fatal error: require() [function.require]: Failed opening required '/home/photogian/room2850.com/wp-includes/post-template.php' (include_path='.:/usr/local/lib/php:/usr/local/php5/lib/pear') in /home/photogian/room2850.com/wp-settings.php on line 119

0

Normally, you'll get those kinds of results because you have file permissions issues. The files all need to be readable and executable by whatever user the WordPress installation is running as (e.g. on most typical webservers, including if you're running LAMP/MAMP locally, it's usually something like the www user and staff group). You'll need to check the permissions and set them correctly. If you're on a Linux or Unix (including Mac) setup you can use a combination of chown and chmod to set the permissions correctly:

In the root directory of your WordPress install, you'll need to run something like (though not necessarily exactly this; it depends on your setup):

$ chown -R www:staff *
$ chmod -R 755 *

I believe you may also need to repeat those commands thus:

$ chown -R www:staff .*
$ chmod -R 755 .*

This way you'll catch some of the hidden files (e.g. the .htaccess file).

Also, you may need root permissions to do this, in which case you'd need to run those thus:

$ sudo chown -R www:staff *
$ sudo chown -R www:staff .*
$ sudo chmod -R 755 *
$ sudo chmod -R 755 .*

If you're using a GUI administration tool (like MAMP Pro, for example), you'll often find a Permissions setting somewhere there. In MAMP Pro, you can set all the permissions in a directory to be what they should using the Permissions button on the General tab in the Hosts area. There are likely similar settings in any XAMPP or Linux administration GUI.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.