1

I was really searching here for a solution for this but I couldn't find anything.

Problem: br and/or br / tags which I put into my content on the backend were just not showing up on the frontend. No matter what I did - enter+shift in the visual or insert the tags manually in the html editor - I tried several things but nothing worked. Interesting fact: on the page I am working have already been a few br's which are working without any problems, so I looked through the code if there was something but I still couldn't find anything.

I found an acceptable solution for this: Simple Breaks. This plugin gives me the possibility to insert br tags by writing the shortcode "[br]". I'm kinda fine with that.

Still I truely want to ask you if you have similiar problems or if there is any solution to this! It is known that WP has it's problems with br's and p's so I guess the users just have to go with it.

Greetings from germany and pls don't be too hard on my bad english :)

More information:

  • I already unchecked "WordPress should correct invalidly nested XHTML automatically" in Admin > Settings > Writing. (thanks to PoseLab)
  • I installed TinyMCE Advanced and checked "Stop removing the

    and
    tags when saving and show them in the HTML editor"

1

May be you have to check the template, its possibile that it may have: remove_filter('the_content','wpautop'); or any other function that has to do with the_content and strip_tags usally they are located in theme functions.php

| improve this answer | |
-1

You have to uncheck the field "WordPress should correct invalidly nested XHTML automatically" in Admin > Settings > Writing

| improve this answer | |
  • Thanks for the tip, I should have provided more information: it already is unchecked. – tommygun Apr 10 '13 at 13:12
  • I think this problem is caused by TinyMCE Advanced. Disable it and test if it works without the plugin. I used to put this plugin on all installations and I stopped using it for this kind of formatting problems. – PoseLab Apr 10 '13 at 13:33
  • I had this problem before already. I installed TinyMCE hoping that it solves that problem :(. – tommygun Apr 11 '13 at 6:17
  • That option does what it says: automatically correct invalidly nested XHTML. It doesn't remove <br> tags, which aren't nested. Instead, wpautop() is the likely culprit. – swissspidy Dec 4 '16 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.