2

I am getting the following error when I try to access my Wordpress website. It was working quite fine previously. Could anyone help me on this.

No configuration file found and no installation code available. Exiting...

1

In Wordpress there will be a default wp-config.php file and I think this has been missing from your package. Please Check if it is there, else create a new one with file name wp-config.php and Place the following code in it with appropriate Database Credentials.

<?php
// ** MySQL settings ** //
define('DB_NAME', 'DATABASE-NAME');    // The name of the database
define('DB_USER', 'DATABASE-USERNAME');     // Your MySQL username
define('DB_PASSWORD', 'DATABASE-PASSWORD'); // ...and password
define('DB_HOST', 'localhost');  
define('DB_CHARSET', 'utf8');
define('DB_COLLATE', '');

// You can have multiple installations in one database if you give each a unique prefix
$table_prefix  = 'wp_';   // Only numbers, letters, and underscores please!

// Change this to localize WordPress.  A corresponding MO file for the
// chosen language must be installed to wp-content/languages.
// For example, install de.mo to wp-content/languages and set WPLANG to 'de'
// to enable German language support.
define ('WPLANG', '');

/* That's all, stop editing! Happy blogging. */

define('ABSPATH', dirname(__FILE__).'/');
require_once(ABSPATH.'wp-settings.php');
?>
|improve this answer|||||
  • ok i will check that and revert back – Thejdeep Apr 8 '13 at 9:58
  • thanks uzair that one solved my issue thanks alot....!You are awesome....! – Thejdeep Apr 8 '13 at 10:12
0

If you have a wp_config.php file, and you can viw the home page but not the internal pages, try changing the Permalinks style.

This can sometimes fix issues with .htaccess settings.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.