After moving my site to a new VPS cloud server, things worked fine for a couple of days, but this morning all of the thumbs and pictures stopped showing, even though they're still in the same directory as before.

Also, if I open the media library through WP console, all of the pictures show and when opening any of the posts for editing the pictures are also there.

After contacting my hosting service, I was told that they were not going to help me, even though they changed something, as they were working on another issue overnight.

The message below shows the message I get when following any of the pictures path on the browser:

A TimThumb error has occured
The following error(s) occured:

You may not fetch images from that site. To enable this site in timthumb, you can either add it to $ALLOWED_SITES and set ALLOW_EXTERNAL=true. Or you can set ALLOW_ALL_EXTERNAL_SITES=true, depending on your security needs.

Query String: src=http://i0.wp.com/ovnihoje.com/wp-content/uploads/2013/04/dyatlov.jpg?resize=269%2C80&h=80&w=269&a=t&zc=1

TimThumb version : 2.8

The timthumb file is set to 'allow_external' but even so it doesn't work. Also, I don't know where that "i0.wp.com" in the URL came from, because the URL for my site is only ovnihoje.com.

4 Answers 4


The problem is not with TimThumb, it's with how you are calling TimThumb. Looking at your site, it is trying to load:


If you update the theme or TimThumb config to pass the correct parameters, it will work:


Since you recently migrated it's likely that you have been pointing to the hold wp.com domain since you moved, and only now are the images no longer available on their server.

  • Thanks for pointing out where the problem is. The site was on a self hosting server before migrating. Since I'm not very proficient with this, could you tell me which file I should edit to point to the correct path?
    – user31002
    Apr 4, 2013 at 19:53
  • 1
    You already updated the WP_HOME and WP_SITEURL? If so my guess is that these are being stored as meta values with the wrong URL, but I would have to look at the theme to know for sure. Apr 4, 2013 at 20:02
  • Yes, both point to ovnihoje.com. I'd greatly appreciate any help.
    – user31002
    Apr 4, 2013 at 21:46
  • Thank you very much doublesharp. See the solution below. I appreciated your help. It guided me straight to the problem.
    – user31002
    Apr 4, 2013 at 21:52

It looks you have moved from a wordpress.com site to self hosting - is that correct? Your timthumb paths are still pointing to wordpress.com (i0.wp.com), which is why they fail.

Is timthumb part of a plugin that you are using, or part of your theme? However it is coming into play, you need to at least update the paths it is using. Ideally, you would eliminate the use of timthumb entirely, but that may be a bigger job.

  • it looks like it's part of the "ChannelPro" plugin, according to the img src. Apr 4, 2013 at 19:25
  • Actually it was on a self-hosting before and even after migrating the site worked fine for some days before the problem occurred mysteriouly. And the timthumb is part of the theme. Thanks
    – user31002
    Apr 4, 2013 at 19:50
  • ^ by "plugin" I meant "theme" Apr 4, 2013 at 20:01
  • It worked temporarily either because some caching was taking place, or because wordpress.com were still delivering your images, which has now stopped.
    – vancoder
    Apr 4, 2013 at 20:39
  • I figured out what was happening. Without your tips I wouldn't be able to figure out the problem. It so happened that the photon plugin in jetpack was somehow activated (and I swear I didn't do it) :) Thank you all very much!
    – user31002
    Apr 4, 2013 at 21:51

I had the same issue of loading images from (http://i0.wp.com) but i figure out by disabling Photon in Jackpack, hopefully someone find the answer helpful.


Set allow_all_external_sites=true in your timthumb.php file in the particular plugin.

  • Please explain why this answer is helpful.
    – kaiser
    Jan 29, 2015 at 7:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.