0

I am having a very strange problem. I am migrating old single WP blogs into a newly created WP Network. After creating the new blog on Network and importing the posts,including attachments, images do not appear in posts, nor as thumbnails. I made sure the images were imported from the old blog, they are in the new blog's folder in the server. But browsing to the URL of the image gives a missing image placeholder.

However, if the image is accessed through the main site's (Network's) URL, it appears just fine.

Example: Viewing this message shows nothing: http://2armedia.al-rasid.com/files/2012/09/rabieiee-150x131.jpg

Viewing this shows the image fine: http://al-rasid.com/wp-content/blogs.dir/8/files/2012/09/rabieiee-150x131.jpg

Noting that "2armedia.al-rasid.com" is subsite 8, and that the 1st url is the default url of the image after being imported, and the url given to all images by the network.

I tried everything, including changing the "Upload Path" and "Upload Url Path" settings of the sub blog to "al-rasid.com/wp-content/blogs.dir/8/files" (including the http) , but that didn't help.

I deleted the network and re-created it because this issue drove me crazy, and that didn't resolve it (what are the default values for these two fields anyway?).

Thanks

0

The problem is that thumbnail addresses are coded on the db. When changing a wp installation from one site to an other, you need to make sure that the thumbnail addresses are correct, one way is to use wp-exporter and importer I personaly don't like that option what I normally do is download the entire db, then on a text editor run a search and replace and change my site that is telling the text editor to change something like: 'http://localhost/blabla/wp-content/' to 'http://www.misite.com/wp-content/blog.dir/8' this is the only way I know that a site can be moved with no problem try also search and replace the root path of the site like 'http://localhost/blabla' then just upload the db may be a little tricky since it is a multisite don't know the exact probrems you will find, but I think the answer is on the db addresses of the thumbnails. Hope this helps.

  • Thank you very much Poxtron. The issue is not only with thumnails. I tried also to import the content of old blog via copying the DB (while changing the variables of course), but still, images simply do not work (load) when accessed via the url of the sub-blog, but only if accessed via the url of the main blog, as the example above. – Mouad Mar 29 '13 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.